Bug 475059 - system-config-network-1.5.93-2.fc10.noarch GUI ignores Netmask value and replaces it with value of gateway address
system-config-network-1.5.93-2.fc10.noarch GUI ignores Netmask value and repl...
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 00:42 EST by Scott Dowdle
Modified: 2008-12-07 13:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-07 13:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2008-12-07 00:42:31 EST
Description of problem:

I try to configure eth0 to be a static address and put a value in for the various fields including Netmask.  I put in 255.255.255.0 for the netmask and 192.168.0.1 for the gateway.  I save the settings and activate the interface only to notice that both the netmask and the gateway are set to the value I gave the gateway address.

I opened up the system-config-network again and see that the netmask field contains the gateway value. I change it, save, and exit the program. I open it back up and again... the netmask is set to 192.168.0.1 the value of the gateway.  I'm assuming there is a typo in the source where both fields refer to the same variable?!?

As a result of this bug I was unable to configure my network and had to edit the /etc/sysconfig/network-scripts/ifcfg-eth0 by hand and put the correct value in for the netmask.

I checked another machine and was able to duplicate the bug.


Version-Release number of selected component (if applicable):
system-config-network-1.5.93-2.fc10.noarch

How reproducible:

Open system-config-network and try to manually configure a network card.. and put in a value for netmask... it gets replace by the gateway address.


Expected results:

This should accept the value given to it and retain it.

Additional info:
Comment 1 Scott Dowdle 2008-12-07 13:55:32 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.