Bug 475137 - RFE: Don't flood with e-mails if nothing has changed.
RFE: Don't flood with e-mails if nothing has changed.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum-updatesd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 23:31 EST by Valdis Kletnieks
Modified: 2010-09-01 23:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 13:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2008-12-07 23:31:28 EST
Description of problem:
So I'm sitting at home, and my not-even-on-the-net laptop squawks that it's just received new e-mail.  Turns out it's yum-updatesd telling me there's a problem updating the system.  True - several RPMs can't upgrade because it includes an update to a shared lib, and several *other* RPMs haven't dropped updated versions into Rawhide yet, and still need the *old* libraries.

But there's no reason to send out 27 e-mails, once per hour.  Nothing has changed since the last time it nagged me.

Recommended change - do a stat() on the involved yum database files and the RPM databases - if none have an mtime less than $run_interval seconds ago, then nothing has changed, so don't bother telling the admin *again*.  Oh, and probably should include /etc/yum/yum-updatesd.conf in the list of files to stat, so it DTRT even on the first iteration.

Version-Release number of selected component (if applicable):
yum-3.2.20-6.fc11.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2008-12-08 13:06:12 EST
The checking (and thus the email) is only done at run_interval.  The default run interval is once an hour though.
Comment 2 Aleksey Nogin 2010-09-01 23:51:03 EDT
IMO it *is* a bug - there is a difference between the "check interval" (1 hour is reasonable) and a "renotification" interval (1 hour is definitely unreasonable for email). Currently yum-updatesd lacks the much needed capability to differentiate between the two. Definitely a valid RFE - which I previously reported as bug 458311 (closed wontfix as well), tried reporting through the RHEL support channel, but somehow can't get anyone to agree it's a valid problem.

Note You need to log in before you can comment on or make changes to this bug.