Bug 475158 - Xorg is using 100% cpu
Xorg is using 100% cpu
Status: CLOSED DUPLICATE of bug 474586
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 03:55 EST by Steve
Modified: 2008-12-09 13:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 13:04:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (171.22 KB, application/octet-stream)
2008-12-08 04:01 EST, Steve
no flags Details
Xorg log (251.31 KB, text/plain)
2008-12-08 04:19 EST, Alexander Dutton
no flags Details

  None (edit)
Description Steve 2008-12-08 03:55:44 EST
Description of problem:
Since the update from F10 to Rawhide, the xserver is using 100% of cpu.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.5.3-5.fc10.i386
xorg-x11-drv-radeonhd-1.2.3-1.7.20081206git.fc11.i386

How reproducible:
When the screensaver goes on, cpu goes to normal state, but the screensaver does present a black screen.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve 2008-12-08 04:01:24 EST
Created attachment 326102 [details]
Xorg.0.log
Comment 2 Alexander Dutton 2008-12-08 04:19:55 EST
Created attachment 326104 [details]
Xorg log

I'd like to second this one. Same circumstances (well, was on rawhide before the F10 release).

Xorg acts normally at GDM and then hits 100% on one core after login.

xorg-x11-server-Xorg.x86_64         1.5.3-5.fc10          installed
xorg-x11-drv-i810.x86_64            2.5.0-3.fc11          installed
Comment 3 John Ellson 2008-12-08 07:58:22 EST
I'm seeing this one too, in my case with the Nvidia 180.11 driver.

However, this only happens with the Gnome desktop, if I log in with KDE then Xorg cpu usage is normal.

xorg-x11-server-Xorg-1.5.3-5.fc10.x86_64
Comment 4 John Ellson 2008-12-08 08:07:00 EST
Something to do with gnome-screensaver maybe?    I just switched to xscreensaver and the Xorg cpu usage dropped to normal.   I tried to switch back to gnome-screensaver, but I don't seem to be able to recreate the problem.
Comment 5 Steve 2008-12-08 08:50:08 EST
Yes, it has something to do with gnome-screensaver. By killing it, the high cpu-usage is gone. Should i switch bug to gnome-screensaver?
Comment 6 Steve 2008-12-09 13:04:03 EST

*** This bug has been marked as a duplicate of bug 474586 ***

Note You need to log in before you can comment on or make changes to this bug.