Bug 475204 - Xorg takes 100% of CPU
Xorg takes 100% of CPU
Status: CLOSED DUPLICATE of bug 474586
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 09:45 EST by Zdenek Kabelac
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 11:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-12-08 09:45:14 EST
Description of problem:

After upgrade to the latest version of  gnome-screensaver package
gnome-screensaver-2.25.1-2.fc11.x86_64 I've noticed that
my Xorg is spinning on one CPU - actually it was note easily detecable that the buggy program is screensaver - but after a while I've found it.

It seems that Xorg loops here:

PU: Core 2, speed 2201 MHz (estimated)
Counted CPU_CLK_UNHALTED events (Clock cycles when not halted) with a unit mask of 0x00 (Unhalted core cycl
es) count 100000
samples  %        image name               app name                 symbol name
-------------------------------------------------------------------------------
  1         0.1451  libfb.so                 Xorg          fbCreateGC
  688      99.8549  intel_drv.so             Xorg          _fini
4819     29.6062  Xorg                     Xorg         dixLookupPrivate
  4819     100.000  Xorg                     Xorg      dixLookupPrivate [self]
-------------------------------------------------------------------------------
1494      9.1786  intel_drv.so             Xorg           I830BlockHandler
  1494     100.000  intel_drv.so             Xorg         I830BlockHandler [self]
-------------------------------------------------------------------------------

As a fix I've renamed binary to avoid starting of screensaver in any case.


Version-Release number of selected component (if applicable):
gnome-screensaver-2.25.1-2.fc11.x86_64

How reproducible:
start gnome-session  with gnome-screensaver

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 jmccann 2008-12-08 11:37:00 EST

*** This bug has been marked as a duplicate of bug 474586 ***

Note You need to log in before you can comment on or make changes to this bug.