Bug 475252 - yum-complete-transaction == NameError: global name 'os' is not defined
yum-complete-transaction == NameError: global name 'os' is not defined
Status: CLOSED DUPLICATE of bug 470458
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 12:35 EST by Jóhann B. Guðmundsson
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 12:38:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-12-08 12:35:28 EST
Description of problem:

[root@localhost ~]# yum-complete-transaction
Loaded plugins: presto, refresh-packagekit
Setting up and reading Presto delta metadata
No Presto metadata available for rawhide
There are 1 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 35 elements left to run
Nothing in the unfinished transaction to cleanup.
Cleaning up completed transaction file
Traceback (most recent call last):
  File "/usr/sbin/yum-complete-transaction", line 208, in <module>
    util = YumCompleteTransaction()
  File "/usr/sbin/yum-complete-transaction", line 115, in __init__
    self.main()
  File "/usr/sbin/yum-complete-transaction", line 189, in main
    self.clean_up_ts_files(timestamp, self.conf.persistdir)
  File "/usr/sbin/yum-complete-transaction", line 123, in clean_up_ts_files
    if os.path.exists(f):
NameError: global name 'os' is not defined

Version-Release number of selected component (if applicable):

[root@localhost ~]# rpm -qa | grep yum
PackageKit-yum-0.3.11-3.fc10.i386
yum-presto-0.4.5-1.fc9.noarch
yum-3.2.20-4.fc11.noarch
PackageKit-yum-plugin-0.3.11-3.fc10.i386
yum-metadata-parser-1.1.2-10.fc10.i386
yum-utils-1.1.18-2.fc11.noarch

How reproducible:

Always

Steps to Reproduce:
1. yum-complete-transaction
2.
3.
  
Actual results:

The above

Expected results:

yum-complete-transaction to finish without errors..
Additional info:
Comment 1 seth vidal 2008-12-08 12:38:03 EST

*** This bug has been marked as a duplicate of bug 470458 ***

Note You need to log in before you can comment on or make changes to this bug.