Bug 47530 - Install tracebacks and exits abnormally upon X server startup failure -- Toshiba Satellite Pro 480CDT
Install tracebacks and exits abnormally upon X server startup failure -- Tosh...
Status: CLOSED DUPLICATE of bug 45544
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-05 19:35 EDT by Panic
Modified: 2007-04-18 12:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-10 01:15:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panic 2001-07-05 19:35:13 EDT
Description of Problem: 

CD-ROM graphical install attempts fail with the below error.  Text
installations work.

Running anaconda - please wait...
Probing for video card: Chips & Technologies CT65555
Probing for monitor type: Unable to probe
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Waiting for X server to start...log located in /tmp/X.log
.. X server started successfully.
Traceback (innermost last):
     File "/usr/bin/anaconda", line 421, in ?
          from splashscreen import splashScreenShow
     File "/usr/bin/anaconda/splashscreen.py", line 20, in ?
          from gtk import *
     File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
          _gtk.gtk_init()
RuntimeError: cannot open display
install exited abnormally
...


How Reproducible: Always


Steps to Reproduce:
1. Attempt a Fairfax beta1 graphical installation on a Satellite Pro 480CDT
2. 
3. 

Actual Results:

Traceback and anaconda failure


Expected Results:

boot into the graphical installation, or ditch to the text install


Additional Information:

It worked in 7.1, so it has to be something recent that was changed.  The
screen never blinks into the X server -- all I see is text, so the X server
startup just doesn't happen.  Alt-F7 is inaccessible.  Alt-F3 shows this error:

* ERROR - trying to run fbconProbe w/o knowing fb device!!

During a 7.1 install this error is not present.  I am booting off of the
boot.img boot disk because this machine's CD-ROM is not bootable (despite
the setting in the BIOS).

lspci -vn shows this on the video card:

00:04.0 Class 0300: 102c:00e5 (rev c6)
     Subsystem: 1179:0001

and -vb identifies the card as a Chips and Technologies F65555 HiQVPro,
with the subsystem ID'd as a Toshiba America Info Systems Unknown.  The
machine is available for testing as needed.
Comment 1 Brent Nordquist 2001-07-09 23:15:27 EDT
I have this one too, and would be willing to test a pre-release fix.
Comment 2 Brent Fox 2001-07-10 01:15:25 EDT

*** This bug has been marked as a duplicate of 45544 ***

Note You need to log in before you can comment on or make changes to this bug.