Bug 45544 - Failure to start X on a Toshiba Tecra 8000
Failure to start X on a Toshiba Tecra 8000
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 46879 47063 47530 48103 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-22 12:17 EDT by David Lawrence
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-26 09:12:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2001-06-22 12:17:46 EDT
Description of Problem:
Graphical install failes on Toshiba Tecra 8000 laptop with Neomagic 256V
chipset. Works
fine with 7.1.

How Reproducible:
Always

Steps to Reproduce:
1. use pcmcia.img and pcmciadd.img to boot into installer
2. choose NFS install
3. watch it try to initialize X

Actual Results:

WAiting for X server to start...log located in /tmp/X.log
...X server started successfully
Traceback (innermost last)
	File "/usr/lib/anaconda", line 394 in ?
		from gui import display_splash_screen
	File "/usr/lib/anaconda/gui.py", line 6, in ?
		from gtk import *
	File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
		_gtk.gtk_init()
RuntimeError: cannot open display
install exited abnormally

On VC# 3 the following appears at the bottom:
ERROR - trying to run fbconProbe w/o knowing fb device!!

On VC# 4 the following appears at the bottom:
<3>Vesafb does not support changing the video mode


Expected Results:
Graphical install for 7.1 worked fine on this laptop

Additional Information:
Comment 1 David Lawrence 2001-06-22 12:28:41 EDT
When running with the nofb option I get the following on VC# 1

Probing for video card:	Neomagic 256 (laptop/notebook)
Probing for monitor type:	Unable to probe
Probing for mouse type: 	Generic - 3 button mouse (PS/2)
Traceback ( innermost last )
	File "/usr/lib/anaconda", line 378, in ?
		mousehw)
	File "/usr/lib/anaconda/xserver.py", line 117, in startX
		x.getVideoCard().setXServer(probedServer)
AttributeError: getVideoCard
install exited abnormally
Comment 2 Brent Fox 2001-06-26 14:10:46 EDT
I fixed the problem with nofb mode last night, so that fix should appear in a
tree soon.
Comment 3 Michael Fulbright 2001-06-27 14:30:13 EDT
What was the fix?

Don't commit it before we ship off beta 1.
Comment 4 David Lawrence 2001-06-27 14:44:23 EDT
Using tree /mnt/redhat/test/beta1/i386 I was able to run the graphical installer
with the 'nofb' option but it still fails with a traceback when not using the
option. Wierd because the kernel is obviously running in frame buffer mode since
I get the penguin graphic.
Comment 5 Brent Fox 2001-06-27 14:47:10 EDT
This was committed on Monday.  I tested it and it works.  You can revert it if
you want to, but the old code was broken.  There is no 'x.getVideoCard()', so
going into nofb mode used to crash everytime.


Date: Mon, 25 Jun 2001 18:41:58 -0400
From: Brent Fox <bfox@redhat.com>
Subject: anaconda xserver.py,1.80,1.81
To: anaconda-commits-list@redhat.com

Update of /mnt/devel/CVS/anaconda
In directory devserv.devel.redhat.com:/tmp/cvs-serv28454

Modified Files:
        xserver.py
Log Message:
nofb mode didn't work...now it does

Index: xserver.py
===================================================================
RCS file: /mnt/devel/CVS/anaconda/xserver.py,v
retrieving revision 1.80
retrieving revision 1.81
diff -u -r1.80 -r1.81
--- xserver.py  2001/06/22 23:56:28     1.80
+++ xserver.py  2001/06/25 22:41:56     1.81
@@ -128,9 +128,9 @@
         if not probedServer:
             print "Unknown card"
             raise RuntimeError, "Unable to start X for unknown card"
-
-        x.getVideoCard().setXServer(probedServer)
-        serverPath = '/usr/X11R6/bin/' + x.getVideoCard().getXServer()
+
+        video.primaryCard().setXServer(probedServer)
+        serverPath = '/usr/X11R6/bin/' + video.primaryCard().getXServer()

        # if this fails, we want the exception to go back to anaconda to
        # it knows that this didn't work
Comment 6 Brent Fox 2001-07-02 11:10:46 EDT
*** Bug 46879 has been marked as a duplicate of this bug. ***
Comment 7 Leonid Kanter 2001-07-02 17:48:21 EDT
*** Bug 47063 has been marked as a duplicate of this bug. ***
Comment 8 Brent Fox 2001-07-06 01:05:27 EDT
So dave, when you try nofb mode, do you get the original traceback that you saw
(the gtk_init() problem) or the second traceback?
Comment 9 Brent Fox 2001-07-10 01:15:21 EDT
*** Bug 47530 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2001-07-10 01:16:00 EDT
*** Bug 48103 has been marked as a duplicate of this bug. ***
Comment 11 David Lawrence 2001-07-10 12:20:46 EDT
Using the nofb option, I am able to get a graphical install to work on the
Toshiba laptop using qa0709.3/i386 tree. Still fails when not using the nofb
option with the first traceback I added to this bug report.
Comment 12 Jeremy Katz 2001-07-10 19:05:02 EDT
Could you retest with a tree on July 11th?
Comment 13 David Lawrence 2001-07-11 16:10:16 EDT
Graphical install still works properly with the nofb option but still fails with
a traceback when not using nofb using qa0711.0/i386. I will try it once more
just to make sure the tracebacks are exactly the same since I didnt read it last
time.
Comment 14 Panic 2001-07-11 16:45:01 EDT
Satellite Pro 480CDT also fails on PCMCIA graphical network install, qa0711.0,
same place.  Traceback looks like this:

Probing for video card: Chips & Technologies CT65555
Probing for monitor type: Unable to probe
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Waiting for X server to start...log located in /tmp/X.log
...X SERVER FAILEDWaiting for X server to start...log located in /tmp/X.log
. X server started successfully.
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    from splashscreen import splashScreenShow
  File "/usr/lib/anaconda/splashcreen.py", line 21, in ?
    from gtk import *
  File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
    _gtk.gtk_init()
RuntimeError: cannot open display
install exited abnormally
...

**********

With the "nofb" option, I get this:

Probing for video card: Chips & Technologies CT6555
Probing for monitor type: Unable to probe
Probing for mouse type:  Generic - 3 Button Mouse (PS/2)
Waiting for X server to start...log located in /tmp/X.log
...X SERVER FAILED X startup failed, falling back to text mode
Traceback (innermost last):
  File "/usr/bin/anaconda", line 559, in ?
    instClass.setKeyboard(id, keymap)
  File "/usr/lib/anaconda/installclass.py", line 171, in setKeyboard
    apply(id.xconfig.setKeyboard, xkb)
AttributeError: 'None' object has no attribute 'setKeyboard'
install exited abnormally
...

*********

Text installation works from qa0711.0, via PCMCIA boot disks.
Comment 15 Michael Fulbright 2001-07-18 16:39:55 EDT
Try beta 3 is should handle this better.
Comment 16 Leonid Kanter 2001-07-24 10:01:57 EDT
I got this on beta2 and satellite pro 440 cdt. fb or nofb - no difference.

Probing for video card: Chips & Technologies CT65554
Probing for monitor type: Unable to probe
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Waiting for X server to start...log located in /tmp/X.log
...X SERVER FAILEDWaiting for X server to start...log located in /tmp/X.log
. X server started successfully.
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    from splashscreen import splashScreenShow
  File "/usr/lib/anaconda/splashcreen.py", line 21, in ?
    from gtk import *
  File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
    _gtk.gtk_init()
RuntimeError: cannot open display
install exited abnormally

Comment 17 Leonid Kanter 2001-07-25 03:31:06 EDT
I got this on beta2 and satellite pro 440 cdt. fb or nofb - no difference.

Probing for video card: Chips & Technologies CT65554
Probing for monitor type: Unable to probe
Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Waiting for X server to start...log located in /tmp/X.log
...X SERVER FAILEDWaiting for X server to start...log located in /tmp/X.log
. X server started successfully.
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    from splashscreen import splashScreenShow
  File "/usr/lib/anaconda/splashcreen.py", line 21, in ?
    from gtk import *
  File "/usr/lib/python1.5/site-packages/gtk.py", line 29, in ?
    _gtk.gtk_init()
RuntimeError: cannot open display
install exited abnormally
Comment 18 Michael Fulbright 2001-07-25 17:44:20 EDT
Please report your luck with beta 3.
Comment 19 Panic 2001-07-26 09:12:52 EDT
Works correctly with beta3 on the Toshiba Satellite 480CDT.
Comment 20 David Lawrence 2001-07-27 17:16:52 EDT
Works correctly on the Toshiba Tecra 8000 with the qa0727.2/i386 tree. Closing.

Note You need to log in before you can comment on or make changes to this bug.