Bug 475623 - Kopete not patched to use libv4l
Kopete not patched to use libv4l
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 476445 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 15:25 EST by Eli Wapniarski
Modified: 2009-04-28 09:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: 4.2.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 15:58:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 177338 None None None Never

  None (edit)
Description Eli Wapniarski 2008-12-09 15:25:03 EST
Fedora 10 x86_64
kernel 2.6.27.5-117.fc10.x86_64
kde 4.18
kopete 0.60.81 

I've just opened a bug report at kde regarding kopete. I hope that I've referenced the right kde package.

Anyway, The problem is that recent kernels uses libv4l to access the camera. If kopete is not patched then the application needs to be started with

LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so kopete -caption "%c" %u

I'm hoping that it would be possilbe to get kopete patched so that my camera can run straight out of the box.


The bug report at kde is located at:

https://bugs.kde.org/show_bug.cgi?id=177338
Comment 1 Rex Dieter 2008-12-09 15:32:22 EST
Thanks, we can give it a whirl.
Comment 2 Hans de Goede 2008-12-15 09:18:43 EST
*** Bug 476445 has been marked as a duplicate of this bug. ***
Comment 3 Steven M. Parrish 2009-01-10 10:19:12 EST
Ping?
Comment 4 Rex Dieter 2009-01-10 11:18:32 EST
targetting kde-4.2
Comment 5 Kevin Kofler 2009-01-24 04:07:32 EST
Jreznik, you wanted to work on this? What's the status? Can we get that done soon or should we target a later update (a separate kdenetwork update or the 4.2.1 update)?
Comment 6 Jaroslav Reznik 2009-01-26 08:34:24 EST
Later update pls, I have some other work now. I'd like to finish it ASAP but I can't guarantee it.
Comment 7 Kevin Kofler 2009-01-26 10:36:04 EST
Let's take this off the 4.2 blocker then. It can be addressed later, it's not a 4.2 regression.
Comment 8 Jaroslav Reznik 2009-01-26 11:13:48 EST
I've prepared easy patch - not upstreamable but should work, we are testing it with ltinkl - his webcam is affected by this bug.
Comment 9 Steven M. Parrish 2009-04-27 14:28:05 EDT
jreznik any movement on this?
Comment 10 Kevin Kofler 2009-04-27 15:58:13 EDT
We have libv4l support in Kopete since 4.2.0-3.
Comment 11 Jaroslav Reznik 2009-04-28 09:26:45 EDT
We have basic support for libv4l, it's already in upstream.

Note You need to log in before you can comment on or make changes to this bug.