Bug 475713 - Packagekit vs. broken dependencies
Packagekit vs. broken dependencies
Status: CLOSED DUPLICATE of bug 475074
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 22:10 EST by Davide Repetto
Modified: 2008-12-10 04:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 04:04:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2008-12-09 22:10:12 EST
Packagekit gives up too easily on broken dependecies
Instead it should (at least) try and skip brokens, as "yum --skip-broken" would.

Such a behaviour shall be very useful when packages in updates break dependencies. And they do!

Examples:
Very recently "gnome-packagekit" wreaked havoc to upgrades and to network installations for days, and the very same day it got fixed... Well, a new breakge arised; courtesy of the current update of "libspectrum".


note:
This problem hits hard "Anaconda" as well. A couple of "network upgrades" and installs that I tried during the "gnome-packagekit" period did some really bad juju. (The upgrade was a complete train wreck!)
Comment 1 Richard Hughes 2008-12-10 04:04:57 EST
It does do --skip-broken. This bug is fallout of 475074.

*** This bug has been marked as a duplicate of bug 475074 ***

Note You need to log in before you can comment on or make changes to this bug.