Bug 475747 - Keyboard repeat settings don't do anything
Keyboard repeat settings don't do anything
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 486944 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 04:18 EST by Felipe Contreras
Modified: 2018-04-11 04:32 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 12:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file (480 bytes, text/plain)
2009-01-06 20:37 EST, Matthieu Heimer
no flags Details
xorg log file (23.63 KB, text/plain)
2009-01-06 20:38 EST, Matthieu Heimer
no flags Details
Xorg log. (121.36 KB, text/plain)
2009-01-17 05:58 EST, Felipe Contreras
no flags Details

  None (edit)
Description Felipe Contreras 2008-12-10 04:18:19 EST
How reproducible:
Always.

Actual results:
Nothing happens.

Expected results:
The keyboard repeat rate should be updated.
Comment 1 Matthieu Heimer 2008-12-21 04:19:56 EST
Same problem, installed F10 from live CD, all updates as of Dec 20 are installed.

Using Preferences -> Hardware -> Keyboard I can turn off the repeat but adjusting the delay has no effect at all. The default delay seems rather short and is driving me nuts.
Comment 2 Matthieu Heimer 2008-12-21 05:25:57 EST
Seems to be related to the new evdev driver being used instead of the old kbd driver (https://fedoraproject.org/wiki/Features/EvdevInputDriver)

Found some more info and workarounds at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/264196

I appended one line to /etc/rc.local
/usr/bin/kbdrate -r 25 -d 500
Comment 3 James Ralston 2008-12-22 23:53:07 EST
I'm having problems with this as well, but I'm seeing slightly different behavior.

Specifically, the repeat rate I want (30 cps) is in effect for the first second or so, but then the repeat rate *changes* to a slower rate (maybe 15 cps or so). Furthermore, I don't see the problem all the time. I haven't quite pinned down what causes the rate-shift behavior to occur (although I suspect executing ACPI suspend/resumes is involved).

Using kbdrate as per comment 2 gets rid of the two-phase repeat rate effect whenever it crops up.
Comment 4 Matt Castelein 2008-12-23 21:56:52 EST
(In reply to comment #1)
> Using Preferences -> Hardware -> Keyboard I can turn off the repeat but
> adjusting the delay has no effect at all. The default delay seems rather short
> and is driving me nuts.

I agree, I have the speed slider set all the way to "slow" and the delay slider set all the way to "long" and nothing seems to change.. It's so fast I am going to break my backspace key with all the unwanted repeats I keep having to delete!
Comment 5 Matěj Cepl 2009-01-06 19:10:15 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Matthieu Heimer 2009-01-06 20:37:31 EST
Created attachment 328336 [details]
xorg config file
Comment 7 Matthieu Heimer 2009-01-06 20:38:47 EST
Created attachment 328337 [details]
xorg log file
Comment 8 Matěj Cepl 2009-01-08 13:33:23 EST
Felipe, do we have some your current /var/log/Xorg.0.log, please?
Comment 9 Felipe Contreras 2009-01-17 05:56:59 EST
Matej: I'm attaching mine, but I don't see the point since Matthieu already did that.
Comment 10 Felipe Contreras 2009-01-17 05:58:43 EST
Created attachment 329277 [details]
Xorg log.
Comment 11 Matěj Cepl 2009-01-19 18:35:24 EST
(In reply to comment #9)
> Matej: I'm attaching mine, but I don't see the point since Matthieu already did
> that.

Thanks a lot -- well, I prefer to have one guy (preferably reporter) whom I can torture to get information/testing from him ;-).
Comment 12 Peter Hutterer 2009-02-25 23:13:50 EST
*** Bug 486944 has been marked as a duplicate of this bug. ***
Comment 13 Trevor Cordes 2009-02-26 08:49:53 EST
To bring over my bug 486944 info here.  This behaviour exists with both evdev and the old kbd driver.  See my bug for further details, as it's a bit different.  I want to be able to go ABOVE 30cps, to 50 or 60cps.

From my tests, you can always set the delay and rate using xset from the command line, up to 30cps using:  xset r rate 200 30

It just won't let you go above.  The old OS's, like F8 and F5, let you go to arbitrary speeds, and it worked.
Comment 14 JM 2009-02-27 07:44:23 EST
So far the only solution which worked for me was to add

Option "AutoAddDevices" "off"

to the ServerFlags in /etc/X11/xorg.conf

This disables the EVDEV driver from Xorg and the "old" KBD driver takes over, this way the keyboard repeat rate works again for me.
Comment 15 Trevor Cordes 2009-02-27 12:56:36 EST
Can you confirm that it lets you go over 30cps and still works properly?  That's great news, thanks for the tip.  I'll be coming back to the world of sanity now.
Comment 16 Felipe Contreras 2009-03-13 06:11:00 EDT
I confirm this workaround works. Ohh, relief.
Comment 17 Trevor Cordes 2009-04-07 02:11:42 EDT
Yes, #14 works ok.  However, I just figured out why sometimes things seem to change for no reason.  I use the pageup/down keys a lot and sometimes accidentally hit numlock.  Today I must have hit it for the first time, as after I hit it my repeat rate changed and the mouse rate changed too (I think).  My kb rate is usually around 200/50.  After numlock it went to what felt like 100/80!  So I run xset to change it back and now it feels like it won't go higher than 45 or so.  And it just feels different, like all of a sudden some resolution changed in both the kb and mouse.  Very weird.

Anyhow, I can trigger the switch to 100/80 by hitting numlock.  I'm pretty sure this happened before I implemented #14 also, though I didn't spot the cause then.

I'm now using the kbd driver and the #14 workaround option.  My kbd rate is usually 200/50 and my mouse "xset m 13/8 0".

This never happened in F8 as I must have accidentally hit numlock 10000 times in F8 without this ever showing up.
Comment 18 Felipe Contreras 2009-06-06 08:00:50 EDT
I'm using F11 live CD and I can't reproduce the problem.
Comment 19 Matěj Cepl 2009-06-25 12:48:49 EDT
Thanks, closing per last comments.

Note You need to log in before you can comment on or make changes to this bug.