Bug 486944 - keyboard repeat rate won't go higher after F8->F10 upgrade
keyboard repeat rate won't go higher after F8->F10 upgrade
Status: CLOSED DUPLICATE of bug 475747
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 07:36 EST by Trevor Cordes
Modified: 2009-02-25 23:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 23:13:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log - evdev being used (13.21 KB, text/plain)
2009-02-25 12:35 EST, Trevor Cordes
no flags Details
xorg.conf - evdev being used (3.25 KB, text/plain)
2009-02-25 12:36 EST, Trevor Cordes
no flags Details

  None (edit)
Description Trevor Cordes 2009-02-23 07:36:34 EST
Description of problem:
In F8 I had the keyboard repeat rate set to a very fast level, roughly 50-60cps.  I upgraded to F10.  F10 will not let me go above (what feels like) 30.  I repeat, in F8 (and earlier releases) I was able to get repeat rates above 30cps on the same hardware as I'm using now.

The behaviour is the same whether I use the xorg driver kbd or evdev.  Setting Option "AutoRepeat" "200 50" in xorg.conf doesn't help -- maxes out at 30 it seems.  Changing it with System-> Pref-> Hardware-> Keyboard doesn't help.  In fact, on my system the speed slider seems to be completely ignored.

Setting it with xset r rate 200 50 doesn't really help either.  In fact, the rate set here also seems mostly ignored.

However, in most cases if you set the rate really high using xset (say 200 for demonstration), you get some weird behaviour.  Start up a terminal and load a large text file into an editor.  Use the down arrow to move down.  It moves down about 30cps.  The press the up arrow.  It moves up for about 100ms at the prescribed rate (200cps) then keeps repeating at around 30cps!  If you set the repeat rate really high you get this fast initial jump behaviour but only on certain keys!  For instance, up and right do it, but not left and down!  Most alpha chars will do it, as well as backspace.

I also tried killing gnome-settings-daemon and playing around with the settings, but it doesn't help.

It seems every time I upgrade to the new Fedora, I have to fight with the keyboard rate.  I guess I'm the only one who has no patience to wait for 30cps when I want 50+ cps.  Regardless, the aforementioned crazy behaviour is a bug any way you look at it.


Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.1.1-1.fc10.i386
xkeyboard-config-1.4-6.fc10.noarch
xorg-x11-drv-keyboard-1.3.2-1.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386

How reproducible:
always

Steps to Reproduce:
1. xset r rate 200 60  or  System-> Pref-> Hardware-> Keyboard and move rate slider fully to the right.
2.
3.
  
Actual results:
repeat rate tops at 30, but you can achieve 100ms bursts at the desired rate


Expected results:
repeat rate should go to whatever you want, as per F8, up to at least 50cps.

Additional info:
Comment 1 Matěj Cepl 2009-02-25 11:18:34 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Trevor Cordes 2009-02-25 12:35:53 EST
Created attachment 333188 [details]
xorg log - evdev being used
Comment 3 Trevor Cordes 2009-02-25 12:36:21 EST
Created attachment 333189 [details]
xorg.conf - evdev being used
Comment 4 Trevor Cordes 2009-02-25 12:38:32 EST
As per my initial comment, the attachments are what I'm running now, with evdev being used.  The behaviour is the same when I use kbd driver.

I am using the nvidia binary drivers from rpmfusion.  If need be I can retest with the free(speech) drivers, though I doubt this affects the keyboard driver.  I used the nvidia binary drivers in F8 as well, and the repeat rate worked fine.

I have no idea how anyone can work with only 30cps repeat!  It's driving me bonkers!
Comment 5 Peter Hutterer 2009-02-25 23:13:50 EST

*** This bug has been marked as a duplicate of bug 475747 ***

Note You need to log in before you can comment on or make changes to this bug.