Bug 47577 - checkquota does nothing. It does not scan the volume.
Summary: checkquota does nothing. It does not scan the volume.
Status: CLOSED DUPLICATE of bug 40194
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: quota   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-06 05:32 UTC by Need Real Name
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-22 10:58:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-07-06 05:32:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
When running checkquota it dosen't seem to be doing anything.  It will not 
pick up current disk usage from users from before quota's where enabled.

How reproducible:
Always

Steps to Reproduce:
1. added usrquota,grpquota to /etc/fstab for /
2. touched /quota.user and /quota.group
3. ran convertquota to convert to aquota.x files
4. ran checkquota -uvF /
5. quotaon -ua and quotaon -ga

	

Actual Results:  checkquota didn't update the aquota.x files.  Did a 
repquota -augv and it said a user that had over 20 megs of files on the 
system was using 0Kb.

Expected Results:  Should have reported the user to be using 20 megs on 
the volume

Additional info:

I tried this on two different machines with fresh installs of 7.1 and both 
had this problem.  I also re-compiled the source RPM and it did the same 
thing

Comment 1 Preston Brown 2001-07-20 17:48:45 UTC
Would you like to beta test some new quota RPMs?  They are available at:

http://people.redhat.com/pbrown/quota-3.01pre8-1.i386.rpm

I would appreciate your feedback on this package.


Comment 2 Need Real Name 2001-07-20 18:57:33 UTC
I installed your beta quota rpm and now it seems to be working.  I did have to 
force install the rpm because of a file conflict with glibc-devel..  I will let 
you know if I find any other issues, for right now it seems to be working!



Comment 3 Marco 2001-07-21 11:04:25 UTC
I also tried the new quota rpm package, it tried to use quota.user instead aquota.user ?

Comment 4 Marco 2001-07-21 12:37:42 UTC
I deleted all my 'old' aquota.user files , upgraded the RPM packages and made quota.user files and did the usual edquota on my users. 
It seems to work allright, back to quota.user files i guess. 
Repquota is working again and updating again with the right quotas.

Comment 5 Need Real Name 2001-07-21 17:58:52 UTC
I am using the aquota.user files.  I am NOT using the old quota.user files.  I 
did exactly like you are sposed to do and did the convertquota command.  I 
don't know how you can be using the quota.x files, I thought it was a kernel 
issue that changed it to aquota.x not the quota package. But whatever the case 
I am using the aquota.x files, the old style have been deleted.

Comment 6 Marco 2001-07-22 10:58:01 UTC
My machine was a Red Hat 7.0 install, upgraded to 7.1. I converted my quota files to aquota.user files then. Now i upgraded to this beta RPM 
and repquota refused to work cause it was looking for quota.user files (convertquota was to no use ofcourse). I deleted my aquota and did a touch 
/home/quota.user . Then i manually  rebuild my user quotas.


Comment 7 Preston Brown 2001-08-30 16:38:48 UTC

*** This bug has been marked as a duplicate of 40194 ***


Note You need to log in before you can comment on or make changes to this bug.