Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 40194 - quota fails to generate quota files
quota fails to generate quota files
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: quota (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 47577 53466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-11 03:05 EDT by Tibor SANDOR
Modified: 2014-01-21 17:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 06:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:108 normal SHIPPED_LIVE Updated quota package for Red Hat Linux 7.1 2001-08-30 00:00:00 EDT

  None (edit)
Description Tibor SANDOR 2001-05-11 03:05:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Terminal)

Description of problem:
1. quotacheck does not creates aquota.user or aquota.group files.
(freshly installed system with only one partition: /)
2. quotacheck does not repair corrupted aquota files.




How reproducible:
Always

Steps to Reproduce:
(aquota.user is created this way:
touch quota.user
convertquota /
)

1. rm aquota.user
2. quotacheck -u /

Step 2. can be replaced with reset button.
(After unclean shutdown quotacheck should run from /etc/rc.d/rc.sysinit)


Actual Results:  Nothing.

Expected Results:  aquota.user file should be created.

Additional info:
Comment 1 Ward D'Hooghe 2001-05-15 13:13:26 EDT
Try this before you turn on quota: 
convertquota -ug /
Comment 2 Tibor SANDOR 2001-05-16 04:05:50 EDT
man quotacheck says:

If a file(aquota.user and/or aquota.group) is not present, quotacheck will 
create it.

quotacheck is normally run at boot time as an init script located 
in /etc/init.d before enabling disk quotas with quotaon.

Either the man page is incorrect or quotacheck does not do its job.

My opinion is: if something corrupts aquota files (eg.: I deleted them)
quotacheck should recreate or correct them without using convertquota, or any 
other commands.

convertquota is responsible for upgrading quota files, but why should I use for 
a newly installed system.

/etc/rc.d/sysinit runs convertquota if quota.user or quota.group exists, but
if not, then quotacheck does not do anything because there will be no aquota 
files.

Comment 3 Preston Brown 2001-08-30 10:58:05 EDT
agreed, this is being fixed.
Comment 4 Preston Brown 2001-08-30 12:38:44 EDT
*** Bug 47577 has been marked as a duplicate of this bug. ***
Comment 5 Preston Brown 2001-09-10 09:43:35 EDT
*** Bug 53466 has been marked as a duplicate of this bug. ***
Comment 6 Speedy 2001-09-12 06:49:22 EDT
* repquota -ua segfaults after the output of the data
* repquota doesn't seem to print out correct values, because e.g. deleting
files does not change the numbers showed with repquota
Comment 7 Seth Vidal 2001-12-09 22:59:02 EST
I think this bug is still active for rh 7.2 systems

I cannot get quotas on a brand new system to work correctly.

they won't turn on and they won't let me generate new files.

Comment 8 Seth Vidal 2001-12-09 23:37:44 EST
This is definitely still happening on quota 3.01pre9-3 on 7.2

I'm reopening it.

Comment 9 Seth Vidal 2001-12-09 23:45:28 EST
oops, I'd like to reopen it - but I can't. B/c I didn't file it originally.

could we reopen this one? please?

thanks
Comment 10 Seth Vidal 2001-12-09 23:50:20 EST
ok, I'll be quiet, I promise, it is working correctly I was just misreading.

just ignore my last 4 comments.

ugh.

sorry
Comment 11 Peter Abeles 2002-12-29 00:03:47 EST
I seem to be experiencing the exact same bug in Redhat 8.0  the version of quota
that I am using is quota-3.06-5.

The system I am using was a fresh install of 8.0 with the only one file system
(also /).
Comment 12 Mark Adams 2003-07-14 16:12:31 EDT
I'm pretty sure that they mean that you can use quotacheck to create the quota 
file, not that it will automatically be created when quotacheck is run after a 
reboot (from init). You will typically need to use the "-c" parameter to create 
the quota file, which is not done in the init file.

Note You need to log in before you can comment on or make changes to this bug.