This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 475794 - Extremely high usage of memory
Extremely high usage of memory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 476624 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 10:03 EST by Zdenek Kabelac
Modified: 2015-01-14 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:18:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-12-10 10:03:46 EST
Description of problem:

Hi

When I've downgraded from the latest version of gnome-screensaver which eats CPU inside Xorg server - I've just notice one thing - it looks like this application eats over 35MB of my RAM - even if it's not active - i.e. running in the background and waiting for activation.

Does it make any sence to consume this amount of Pixmap memory:


xrestop - Display: localhost:0
          Monitoring 36 clients. XErrors: 1
          Pixmaps:   61823K total, Other:     194K total, All:   62018K total

res-base Wins  GCs Fnts Pxms Misc   Pxm mem  Other   Total   PID Identifier    
4600000     3   27    0    6 1969    34453K     46K  34499K  7546 gnome-screensaver
3a00000  1168  525    1  493  300     8290K     47K   8338K  9234 [SDL] moving screen when u change resolution - Mozilla Firefox
1800000     0    0    0    1    0     6890K	 0B   6890K   ?   <unknown>
0e00000     8   38    1    7   17     4595K	 2K   4598K 18822 nautilus
0000000     1    0    2    0   57     3445K	 3K   3448K   ?   <unknown>
1e00000     0    0    0    1    0     3445K	 0B   3445K   ?   <unknown>


The second window in the row - is the firefox window with over 40 opened tabs - and screensaver still takes 4 times more.... - and I use 'blank' screensaver

I know that memory is cheap, but I think this could be better ;)
It looks like 5 full 32bit screens 1600x1080 saved in the memory...

Version-Release number of selected component (if applicable):
gnome-screensaver-2.24.1-2.fc11.x86_64

How reproducible:


Steps to Reproduce:
1. start gnome session
2. use xrestop
3.
  
Actual results:


Expected results:
Idealy this would be zero when I do not see screensaver activated - is there really any need to keep pixmaps allocated why the screensaver is not active ?



Additional info:
Comment 1 Matthias Clasen 2008-12-14 22:26:35 EST
I've tracked this down, see http://bugzilla.gnome.org/show_bug.cgi?id=564548
Comment 2 Fedora Update System 2008-12-15 12:08:15 EST
gnome-screensaver-2.24.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-screensaver-2.24.1-2.fc10
Comment 3 Ray Strode [halfline] 2008-12-16 16:54:57 EST
*** Bug 476624 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2008-12-17 19:43:53 EST
gnome-screensaver-2.24.1-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-screensaver'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11308
Comment 5 Fedora Update System 2009-01-07 04:18:00 EST
gnome-screensaver-2.24.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.