Bug 476624 - gnome-screensaver leaks large pixbufs
gnome-screensaver leaks large pixbufs
Status: CLOSED DUPLICATE of bug 475794
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 05:06 EST by Grahame Bowland
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-16 16:54:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 564486 None None None Never

  None (edit)
Description Grahame Bowland 2008-12-16 05:06:59 EST
Description of problem:
gnome-screensaver leaks large X11 pixbufs each time a lock/unlock cycle occurs.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.24.1-1.fc10.i386

How reproducible:
Always.

Steps to Reproduce:
1. Run "xrestop" in a terminal window
2. Set the screensaver to "blank screen" (not necessarily required, but that's what I have.)
3. Lock the screen (System->Lock Screen)
4. Let the screen fade out, then log back in (as the same user)
5. Look at xrestop. On my machine (with 2x1600x1200 LCD screens) each iteration of the above steps leaks 30,000KB of Pxm mem.

Actual results:
Large pixbuf is leaked.

Expected results:
Large pixbuf not leaked (pxm mem column largely unchanged after lock/unlock.)

Additional info: 
Running F10 with updates as of today. Reproducable on several computers.
Comment 1 Ray Strode [halfline] 2008-12-16 16:54:57 EST

*** This bug has been marked as a duplicate of bug 475794 ***

Note You need to log in before you can comment on or make changes to this bug.