Bug 475847 - X eats CPU, loadavg 1.01 all the time
Summary: X eats CPU, loadavg 1.01 all the time
Keywords:
Status: CLOSED DUPLICATE of bug 474586
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-10 19:04 UTC by Pete Zaitcev
Modified: 2008-12-11 00:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-11 00:45:57 UTC
Type: ---


Attachments (Terms of Use)

Description Pete Zaitcev 2008-12-10 19:04:52 UTC
Description of problem:

The fans on the laptop are at maximum all the time, apparently it's
caused by X looping.

Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-0.99.2-1.fc11
xorg-x11-drv-ati-6.9.0-61.fc10.x86_64

How reproducible:

Unknown

Steps to Reproduce:
1. Use the system normally

Actual results:

X loops

Expected results:

System idle.

Additional info:

top - 11:58:18 up  3:59,  4 users,  load average: 1.01, 1.03, 0.68
Tasks: 120 total,   2 running, 117 sleeping,   0 stopped,   1 zombie
Cpu(s):  6.1%us, 25.8%sy,  0.9%ni, 63.9%id,  3.1%wa,  0.0%hi,  0.1%si,  0.0%st
Mem:    895668k total,   886692k used,     8976k free,    37784k buffers
Swap:   589816k total,    63124k used,   526692k free,   464456k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 2993 root      20   0  457m  36m 8924 R 96.5  4.2  70:37.44 Xorg               
21296 zaitcev   20   0 14744 1052  788 R  1.9  0.1   0:00.02 top                
    1 root      20   0  4092  560  468 S  0.0  0.1   0:00.55 init               
    2 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 kthreadd           
    3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 migration/0

Only two components listed above were updated in this cycle, so one of
them must be it, unless it's outside of X. Previous versions, working ok:

xorg-x11-drv-ati-6.9.0-59.fc10
xorg-x11-drv-synaptics-0.99.1-2.fc11.x86_64

I'm going to experiment a bit, perhaps it's something in the application
mix (like, broken Firefox update). Although, no other applications eat
CPU together with X.

Comment 1 Jonathan Kamens 2008-12-10 20:57:32 UTC
Also happens on x86.  Also happens with openchrome and vesa drivers.

Comment 2 Pete Zaitcev 2008-12-10 21:48:13 UTC
BTW, kernel would be the most natural culprit, but as it happened X fails
to start on the newest kernel 2.6.28-0.121.rc7.git5.fc11. So I am running
the old, unchanged kernel. The xorg-x11-server-* packages were not updated
since November 24 (xorg-x11-server-Xorg-1.5.3-5.fc10).

Another thing: my X stops using the CPU when screen blanking engages,
no matter what applications are doing. If an input unblanks the screen,
X starts eating CPU again on my system.

Comment 3 Yanko Kaneti 2008-12-11 00:15:53 UTC
Sounds very much like bug 474586

Comment 4 Pete Zaitcev 2008-12-11 00:45:57 UTC
Reverting to gnome-screensaver-2.24.1-2.fc11 on my system resolves the issue.
Duping.

*** This bug has been marked as a duplicate of bug 474586 ***


Note You need to log in before you can comment on or make changes to this bug.