Bug 475947 - enlightenment has an insanely long description
enlightenment has an insanely long description
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 476479 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 03:21 EST by Luya Tshimbalanga
Modified: 2009-01-15 04:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 08:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Description field hijack (114.82 KB, image/png)
2008-12-11 03:21 EST, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2008-12-11 03:21:29 EST
Created attachment 326594 [details]
Description field hijack

Description of problem:


Version-Release number of selected component (if applicable):
0.3.12

How reproducible:
Always

Steps to Reproduce:
1. Type any application containing a long line of description (Enlightenment_
2.
3.
  
Actual results:
Description field takes all height space masking resulting packages.

Expected results:
Description field should not take over package field.

Additional info:
Screenshot included
Comment 1 Richard Hughes 2008-12-11 06:52:58 EST
Wow, that's a long description. I've applied the following patch to git master:

commit 5badab04dbbaf72545bcd677209f21eb51dcbc6f
Author: Richard Hughes <richard@hughsie.com>
Date:   Thu Dec 11 11:50:52 2008 +0000

    bugfix: truncate description fields greater than 1024 bytes in size to fix rh#475947

I'm not going to show all of such insanely long descriptions. Descriptions shouldn't be this long.
Comment 2 Richard Hughes 2008-12-15 04:03:42 EST
*** Bug 476479 has been marked as a duplicate of this bug. ***
Comment 3 Pavel Rosenboim 2008-12-17 05:15:21 EST
Even when description is not that long, it is very annoying when description field suddenly changes its height when clicking on the package. It should have fixed (and preferably, user-adjustable) height and a scrollbar. Truncating the description is not a good idea, IMHO.
Comment 4 Jens Petersen 2008-12-17 18:32:08 EST
Agreed.
Comment 5 Pavel Shevchuk 2008-12-19 06:04:22 EST
Description of enlightenment is fixed in enlightenment-0.16.999.050-1. It's already in rawhide, updates for F-10 and F-9 will be pushed in few days
Comment 6 Richard Hughes 2009-01-14 08:51:42 EST
Cool, thanks.
Comment 7 Jens Petersen 2009-01-14 18:14:39 EST
(In reply to comment #6)
> Cool, thanks.

Erm, and what is happening on the gpk side now?
Comment 8 Richard Hughes 2009-01-15 04:23:22 EST
GPK truncates super long descriptions, and I'm working on making it a scrollable text box for the next major release.

Note You need to log in before you can comment on or make changes to this bug.