Bug 476070 - Screen gets corrupted during use
Summary: Screen gets corrupted during use
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: 10
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-12-11 19:36 UTC by Matthias Runge
Modified: 2018-04-11 12:45 UTC (History)
3 users (show)

Fixed In Version: 6.9.0-62.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-17 10:20:09 UTC
Type: ---


Attachments (Terms of Use)
Xorg.log (65.02 KB, text/plain)
2008-12-11 19:36 UTC, Matthias Runge
no flags Details
Xorg.conf (2.41 KB, text/plain)
2008-12-11 19:46 UTC, Matthias Runge
no flags Details
Xorg.log with no xorg.conf (65.74 KB, text/plain)
2008-12-11 19:51 UTC, Matthias Runge
no flags Details

Description Matthias Runge 2008-12-11 19:36:13 UTC
Created attachment 326656 [details]
Xorg.log

Description of problem:
During use (in about 10-20 minutes, the screen gets some smaller and bigger corruptions, e.g. at chars some pixel seem to slip to left or right. This can be corrected if the whole application (e.g. Firefox, xterm) is redrawn 

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-61.fc10.i386

How reproducible:
Every time. Especially in firefox, select the url line. It gets elevated. At my screen, there show up small lines in the lower corner of url field.

Steps to Reproduce:
1. each time
2.
3.
  
Actual results:


Expected results:
no screen corruption

Additional info:
System is a Thinkpad T43, ATI X300

Comment 1 Matthias Runge 2008-12-11 19:37:24 UTC
This did not show in the previous version of the driver.

Comment 2 Matthias Runge 2008-12-11 19:45:35 UTC
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300] (prog-if 00 [VGA controller])
	Subsystem: IBM Device 056e
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at c0000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 2000 [size=256]
	Memory at b0100000 (32-bit, non-prefetchable) [size=64K]
	[virtual] Expansion ROM at b0120000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel modules: radeon, radeonfb

Memory size is not correct in Xorg.log (reports 64 M), lspci-output is correct

Comment 3 Matthias Runge 2008-12-11 19:46:54 UTC
Created attachment 326658 [details]
Xorg.conf

Xorg.conf

Comment 4 Matthias Runge 2008-12-11 19:51:43 UTC
Created attachment 326661 [details]
Xorg.log with no xorg.conf

Comment 5 Matthias Runge 2008-12-12 21:56:35 UTC
bug is not existant in version xorg-x11-drv-ati-6.9.0-54.fc10
Hmm.

Comment 6 Matthias Runge 2008-12-15 14:06:56 UTC
duplicate of bug no 466369?
https://bugzilla.redhat.com/show_bug.cgi?id=466369

Comment 7 Gordon Messmer 2008-12-16 19:42:55 UTC
Perhaps a duplicate of bug 475555.  I also got general glitches using -61, but not the previous version or -62 from koji.

Comment 8 Matěj Cepl 2008-12-16 22:04:00 UTC
Reporter, could you please test with xorg-x11-drv-ati-6.9.0-62.fc10 from http://koji.fedoraproject.org/koji/buildinfo?buildID=73971 ? Does it help?

Comment 9 Matthias Runge 2008-12-17 07:34:46 UTC
Version 6.9.0-62.fc10 from koji seems to fix my issues. (works for me).
Thank you!

Comment 10 Matěj Cepl 2008-12-17 10:20:09 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.