Bug 476079 - System-config-network writes gateway adress to netmask
System-config-network writes gateway adress to netmask
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
i686 Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 15:10 EST by Heiko Adams
Modified: 2008-12-11 17:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 17:38:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2008-12-11 15:10:00 EST
Description of problem:
When saving changes to a network interface with static ip adress system-config-network writes the gateway adress addtionaly to the netmask field. In case of that the interface hast the gateways ip as its netmask.


Version-Release number of selected component (if applicable):
system-config-network-tui-1.5.93-2.fc10.noarch
system-config-network-1.5.93-2.fc10.noarch

How reproducible:
allways

Steps to Reproduce:
1. Edit a network interface with static ip
2. Save your changes
3. Open the interface configuration again
  
Actual results:
The interfaces netmask is identicly to the gateway adress

Expected results:
The netmask should be what you've configured

Additional info:
The only workaround is to manualy edit the interface script
Comment 1 Jiri Moskovcak 2008-12-11 17:38:11 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.