Bug 476207 - integrity constraint on sync from master if parent key missing
integrity constraint on sync from master if parent key missing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Shannon Hughes
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2008-12-12 08:42 EST by Pradeep Kilambi
Modified: 2009-09-10 16:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-12-12 08:42:30 EST
Description of problem:

sat-sync of custom channels from master satellite throws an integrity constraint if parent key is missing..

# satellite-sync -c iss-test-channel 
23:36:01 Red Hat Network Satellite - live synchronization
23:36:01    url: https://rlx-0-16.rhndev.redhat.com
23:36:01    debug/output level: 1
23:36:05    db:  spacewalk/<password>@xe
23:36:05 
23:36:05 Retrieving / parsing channel-families data
23:36:07 channel-families data complete
23:36:07 
23:36:07 Retrieving / parsing arches data
23:36:11 arches data complete
23:36:11 
23:36:11 Retrieving / parsing additional arches data
23:36:11 additional arches data complete
23:36:11 
23:36:11 Retrieving / parsing channel data
23:36:11    p = previously imported/synced channel
23:36:11    . = channel not yet imported/synced
23:36:11    base-channels:
23:36:11       . iss-test-channel                            0
23:36:11 
AAAAAAAAAAAAAAAAAAAAAAAAAAAA [<server.importlib.importLib.Channel instance; attributes={'source_packages': [], 'product_version': None, 'all-packages': None, 'channel_product_id': None, 'parent_channel': None, 'channel_arch': 'channel-ia32', 'basedir': '/dev/null', 'label': 'iss-test-channel', 'product_name': None, 'families': [[<server.importlib.importLib.ChannelFamily instance; attributes={'product_url': None, 'channels': ['iss-test-channel'], 'label': 'private-channel-family-22', 'channel-family-id': 'rhn-channel-family-1020', 'name': None}]], 'description': None, 'product_beta': None, 'product_name_id': None, 'errata_timestamps': [], 'last_modified': '2008-11-19 11:06:11', 'receiving_updates': 'Y', 'packages': [], 'name': 'iss-test-channel', 'string_channel_id': 'rhn-channel-121', 'gpg_key_url': None, 'kickstartable_trees': [], 'org_id': 22, 'summary': 'iss-test-channel', 'dists': [], 'release': None, 'errata': []}]
CCCCCCCCCCCCCCCCCCCCCC [[<server.importlib.importLib.Channel instance; attributes={'source_packages': [], 'product_version': None, 'all-packages': None, 'channel_product_id': None, 'parent_channel': None, 'channel_arch': 'channel-ia32', 'basedir': '/dev/null', 'label': 'iss-test-channel', 'product_name': None, 'channel_arch_id': 500, 'families': [{'channel_family_id': 1013}], 'description': None, 'product_beta': None, 'product_name_id': None, 'errata_timestamps': [], 'last_modified': '2008-11-19 11:06:11', 'receiving_updates': 'Y', 'packages': [], 'name': 'iss-test-channel', 'string_channel_id': 'rhn-channel-121', 'gpg_key_url': None, 'kickstartable_trees': [], 'org_id': 22, 'summary': 'iss-test-channel', 'dists': [], 'release': None, 'errata': []}]]
+++ sending log as an email +++

SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

<rhnFault class (code = 54, text = 'ORA-02291: integrity constraint (SPACEWALK.RHN_CHANNEL_ORG_FK) violated - parent key not found
')>
(54, 'ORA-02291: integrity constraint (SPACEWALK.RHN_CHANNEL_ORG_FK) violated - parent key not found\n', '\n     Package Upload Failed due to uniqueness constraint violation.\n     Make sure the package does not have any duplicate dependencies or\n     does not already exists on the server\n     ')
Comment 5 Jeff Ortel 2009-07-17 13:02:41 EDT
Reassigned to me as qa_contact.  Similar to bug 509187, I can verify them at the same time.
Comment 6 Shannon Hughes 2009-07-21 13:42:23 EDT
master has more the one org, syncing to slave with just one org. did a sat sync on the base and it looks good.
Comment 7 Steve Salevan 2009-08-10 11:08:09 EDT
RELEASE_PENDING from 7/24 ISO.
Comment 8 Brandon Perkins 2009-09-10 16:04:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.