Bug 509187 - syncing custom channel from non default org db error
syncing custom channel from non default org db error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Tomas Lestach
na
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-07-01 13:14 EDT by wes hayutin
Modified: 2009-09-10 16:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-07-01 13:14:01 EDT
Description of problem:

command:

[root@riverraid rhn]# satellite-sync --iss-parent=grandprix.rhndev.redhat.com   --ca-cert=/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT -c centralsinglsharedchannel


results:


SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

<rhnFault class (code = 54, text = 'ORA-02291: integrity constraint (RHNSAT.RHN_CHANNEL_ORG_FK) violated - parent key not found
')>
(54, 'ORA-02291: integrity constraint (RHNSAT.RHN_CHANNEL_ORG_FK) violated - parent key not found\n', '\n     Package Upload Failed due to uniqueness constraint violation.\n     Make sure the package does not have any duplicate dependencies or\n     does not already exists on the server\n     ')
Comment 1 wes hayutin 2009-07-01 13:15:09 EDT
13:06:48 
SYNC ERROR: unhandled exception occurred:

Exception reported from riverraid.rhndev.redhat.com
Time: Wed Jul  1 13:06:48 2009
Exception type common.rhnException.rhnFault

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 142, in main
    return satsync.Runner().main()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 211, in main
    ret = method()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 285, in _step_channels
    self.syncer.process_channels()
  File "/usr/share/rhn/satellite_tools/satsync.py", line 626, in process_channels
    orgid=OPTIONS.orgid or None)
  File "/usr/share/rhn/satellite_tools/sync_handlers.py", line 210, in import_channels
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 628, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/channelImport.py", line 124, in submit
    self.backend.processChannels(nullParentBatch)
  File "/usr/share/rhn/server/importlib/backend.py", line 865, in processChannels
    'channel_id', uploadForce=4, ignoreUploaded=1, forceVerify=1)
  File "/usr/share/rhn/server/importlib/backend.py", line 1401, in __processObjectCollection
    return self.__processObjectCollection__(objColl, parentTable, childDict, **kwargs)
  File "/usr/share/rhn/server/importlib/backend.py", line 1571, in __processObjectCollection__
    return self.__doDML(dml)
  File "/usr/share/rhn/server/importlib/backend.py", line 1679, in __doDML
    self.__doInsert(dml.insert, dml.tables)
  File "/usr/share/rhn/server/importlib/backend.py", line 1688, in __doInsert
    raise rhnFault(54, str(e[1]), explain=0)
rhnFault: (54, 'ORA-02291: integrity constraint (RHNSAT.RHN_CHANNEL_ORG_FK) violated - parent key not found\n', '\n     Package Upload Failed due to uniqueness constraint violation.\n     Make sure the package does not have any duplicate dependencies or\n     does not already exists on the server\n     ')
Comment 2 wes hayutin 2009-07-01 13:28:06 EDT
this actually works if you specify org=1 on the command line... so this bug is really just an error msg bug
Comment 4 Jeff Ortel 2009-07-16 15:14:45 EDT
Verify blocked by bug 512236
Comment 5 Tomas Lestach 2009-07-24 11:46:19 EDT
1. I successfully iss synced custom channel pair (base & child) from
a non-default master organisation.

VERIFIED with 7/23iso (upgraded Satellite-5.3.0-RHEL5-re20090721.0)!
Comment 6 Sayli Karmarkar 2009-08-12 17:16:22 EDT
Successfully synced custom channel from non-default org. Moving to release_pending.
Comment 7 Brandon Perkins 2009-09-10 16:04:43 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.