Bug 476250 - Port pan 0.133 to new gmime 2.4.x API
Port pan 0.133 to new gmime 2.4.x API
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Dalloz
Fedora Extras Quality Assurance
: Patch
Depends On: 490397
Blocks: F11FTBFS
  Show dependency treegraph
 
Reported: 2008-12-12 12:52 EST by Nicholas Wourms
Modified: 2009-10-12 11:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-10 18:12:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix build (570 bytes, patch)
2008-12-12 12:52 EST, Nicholas Wourms
no flags Details | Diff
build with old gmime (1.85 KB, patch)
2009-02-06 03:11 EST, Yanko Kaneti
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 541676 None None None Never

  None (edit)
Description Nicholas Wourms 2008-12-12 12:52:49 EST
Created attachment 326746 [details]
Patch to fix build

Description of problem:
The pan package fails to build due to enormous changes in the gmime API between gmime-2.2.x and gmime-2.4.x.

Version-Release number of selected component (if applicable):
0.133-1

How reproducible:
Always

Steps to Reproduce:
1. Install gmime-2.4.3-2.
2. Rebuild pan-0.133-1
  
Actual results:
Build fails due to pkg-config error.

Expected results:
Build succeeds.

Additional info:
This bug depends on Bug #476243 being satisfied. The pan package will not build properly even if configure.in is modified to work with gmime-2.4.3. The best resolution is to use the gmime-2.2 library until such time that upstream has been rewritten to use the gmime-2.4 API. Bug #476243 provides for a new package, gmime22, which this will build against. Attached is a patch to pan.spec which will fix the BR to depend on this new package.
Comment 1 Erik van Pienbroek 2009-01-09 18:05:34 EST
Upstream is working on a patch for Pan to support GMime 2.4: http://bugzilla.gnome.org/show_bug.cgi?id=541676
Comment 2 Yanko Kaneti 2009-02-06 03:11:30 EST
Created attachment 331098 [details]
build with old gmime

In the meantime in order to have a package I am using this gross violation to build together with a copy of the old gmime.
Comment 3 Erik van Pienbroek 2009-02-06 06:25:59 EST
That is a 'no-go' as it isn't allowed by the Fedora Packaging Guidelines. See http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries and http://fedoraproject.org/wiki/Packaging:Guidelines#Bundling_of_multiple_projects
Comment 4 Alex Lancaster 2009-03-15 04:31:48 EDT
Lack of a pan patch means that the rawhide package is causing broken deps in Fedora:

Broken deps for i386
----------------------------------------------------------
	1:pan-0.133-1.fc10.i386 requires libgmime-2.0.so.2


(from http://koji.fedoraproject.org/mash/rawhide-20090314/logs/depcheck )

We may have to block the package from the f11-beta, so it would be good if there was a working patch we could apply.
Comment 5 Alex Lancaster 2009-03-20 02:54:11 EDT
We introduced a gmime22 compatibility package:

http://koji.fedoraproject.org/koji/buildinfo?buildID=94842

so this is fixed for F11-beta.  However, since this gmime22 package is intended to only last one cycle, we should leave this bug open to encourage porting to the new gmime 2.4.x API.

Marking patches as obsolete.
Comment 6 Bug Zapper 2009-06-09 06:15:19 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Matt Domsch 2009-06-10 18:12:31 EDT
This is fixed in the first build of Fedora 12 rawhide, and from the comments, much earlier.  Closing.
Comment 8 Erik van Pienbroek 2009-06-10 18:25:32 EDT
Shouldn't this stay open? Pan still doesn't support gmime 2.4 and the gmime22 package is only meant as a temporary solution

Note You need to log in before you can comment on or make changes to this bug.