Bug 476338 - system-config-network crashed with MTU problem
system-config-network crashed with MTU problem
Status: CLOSED DUPLICATE of bug 475155
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 03:43 EST by Luo Bin
Modified: 2008-12-15 05:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 05:32:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luo Bin 2008-12-13 03:43:17 EST
Description of problem:
When save the configed profile with the MTU option of eth0 chosen,program get carshed!

Version-Release number of selected component (if applicable):
Component: system-config-network
Version: 1.5.94

How reproducible:


Steps to Reproduce:
1. open "system-config-network ",and edit the eth0 interface 
2. ticked the MTU option on,then click OK bottom
3. save the config,and will get an crash report!
  
Actual results:

crashed,and give this output:
Summary: TB334155f4 ConfShellVar.py:66:__setitem__:TypeError: expected string or buffer

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 829, in on_applyButton_clicked
    self.save()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 411, in save
    self.saveDevices()
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 431, in saveDevices
    devicelist.save()
  File "/usr/share/system-config-network/netconfpkg/NCDeviceList.py", line 238, in save
    dev.save()
  File "/usr/share/system-config-network/netconfpkg/NCDevice.py", line 413, in save
    conf[confkey] = getattr(self, selfkey)
  File "/usr/share/system-config-network/netconfpkg/conf/ConfShellVar.py", line 66, in __setitem__
    if self.quotereg.search(value):
TypeError: expected string or buffer

Local variables in innermost frame:
varname: MTU
self: <netconfpkg.NCDevice.ConfDevice instance at 0xb66398ac>
place: 15
value: 1500
missing: 1

Expected results:
accept the config profile and exits normally.

Additional info:
Comment 1 Jiri Moskovcak 2008-12-15 05:32:35 EST

*** This bug has been marked as a duplicate of bug 475155 ***

Note You need to log in before you can comment on or make changes to this bug.