Bug 476389 - system-config-services crashes on startup
system-config-services crashes on startup
Status: CLOSED DUPLICATE of bug 475200
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-13 19:49 EST by Joshua Rosen
Modified: 2008-12-15 09:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-15 09:02:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2008-12-13 19:49:44 EST
Description of problem: system-config-services crashes on startup


Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1.su
2.system-config-services
3.
  
Actual results:crashes


Expected results:


Additional info:
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 945, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 900, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PolicyKit" member "IsSystemBusNameAuthorized" error name "(unset)" destination ":1.124")
Comment 1 Andre Robatino 2008-12-14 00:56:19 EST
I find that it runs after "su -", but crashes with the above traceback when either run as an ordinary user, or after "su" (without the dash).  It also crashes when run from the menu (presumably because it starts with ordinary user privileges and/or environment).
Comment 2 Vaclav "sHINOBI" Misek 2008-12-14 06:40:29 EST
Please provide versions of system-config-services, dbus* packages.
Comment 3 Andre Robatino 2008-12-14 07:09:45 EST
I see the same exact behavior on two fully updated machines - one 64-bit, one 32-bit.

64-bit:

system-config-services-0.99.28-3.fc10.noarch
dbus-1.2.8-1.fc10.x86_64
dbus-devel-1.2.8-1.fc10.x86_64
dbus-glib-0.76-3.fc10.x86_64
dbus-glib-devel-0.76-3.fc10.x86_64
dbus-libs-1.2.8-1.fc10.i386
dbus-libs-1.2.8-1.fc10.x86_64
dbus-python-0.83.0-3.fc10.x86_64
dbus-x11-1.2.8-1.fc10.x86_64
ndesk-dbus-0.6.1a-2.fc9.x86_64
ndesk-dbus-glib-0.4.1-3.fc9.x86_64
python-slip-dbus-0.1.15-1.fc10.noarch

The version numbers on the 32-bit box are all the same.
Comment 4 Joshua Rosen 2008-12-14 09:28:16 EST
D-Bus Message Bus Daemon 1.2.8
Comment 5 Nils Philippsen 2008-12-15 09:02:59 EST

*** This bug has been marked as a duplicate of bug 475200 ***

Note You need to log in before you can comment on or make changes to this bug.