Bug 475200 - PolicyKit: incorrect default DBUS configuration
PolicyKit: incorrect default DBUS configuration
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: PolicyKit (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 475122 476088 476389 476939 (view as bug list)
Depends On:
Blocks: 475203
  Show dependency treegraph
 
Reported: 2008-12-08 09:23 EST by Tomas Hoger
Modified: 2013-03-05 22:57 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 19:39:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shows errors during KDE startup (14.59 KB, text/plain)
2008-12-09 14:11 EST, Ian Amess
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18948 None None None Never

  None (edit)
Description Tomas Hoger 2008-12-08 09:23:59 EST
This is a Fedora clone for upstream bug:
  https://bugs.freedesktop.org/show_bug.cgi?id=18948

Recent fix of the DBUS default policy for system bus:
  https://bugs.freedesktop.org/show_bug.cgi?id=18229
  https://bugzilla.redhat.com/show_bug.cgi?id=469151

seems to uncover a bug in PolicyKit default policy.  That policy only polkituser to own org.freedesktop.PolicyKit, but does not specify any allow rules.

If any user is expected to be able to send requests to polkitd over DBUS, policy should probably get something like:

  <policy context="default">
    <allow send_destination="org.freedesktop.PolicyKit"/>
  </policy>

This problem was observed at least with system-config-services.
Comment 1 Fedora Update System 2008-12-08 12:28:01 EST
PolicyKit-0.8-4.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/PolicyKit-0.8-4.fc9
Comment 2 Fedora Update System 2008-12-08 12:29:44 EST
PolicyKit-0.9-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/PolicyKit-0.9-4.fc10
Comment 3 Dario Castellarin 2008-12-08 15:25:02 EST
PolicyKit-0.9-4 doesn't seem to solve the issue, at least on F10 x86_64.
For example, after any yum operation I get this error:

ERROR:dbus.proxies:Introspect error on :1.66:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.DBus.Introspectable" member "Introspect" error name "(unset)" destination ":1.66")

PackageKit-gnome can't even perform a search:

failed to get a TID: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PackageKit.Transaction" member "SetLocale" error name "(unset)" destination "org.freedesktop.PackageKit") (0)
Comment 4 Randall "Randy" Berry 2008-12-08 16:35:45 EST
Auto update alert / PackageKit refresh displays the following error. This error occurs on both F9 and F10

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PackageKit.Transaction" member "Cancel" error name "(unset)" destination "org.freedesktop.PackageKit")
Comment 5 Pedro Lamarão 2008-12-08 17:36:24 EST
Manually firing the "update" thing on Fedora 9 gives me the following error:

A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PackageKit.Transaction" member "GetUpdates" error name "(unset)" destination "org.freedesktop.PackageKit")
Comment 6 Dan Ziemba 2008-12-09 00:25:26 EST
I too am getting this error with system-config-services.  I am also observing something very similar with system-config-samba.  This seems to be the important part of the error:

dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.fedoraproject.Config.Samba.Backend" member "readSmbConf" error name "(unset)" destination ":1.90")

I am running dbus 1.2.6-1, PackageKit 0.3.11-4, and PolicyKit 0.9-3.  This happens with s-c-samba 1.2.67-1 and s-c-services 0.99.28-1.  I am running Fedora 10 i386.

P.S.  With the updated PackageKit I am running, gpk-application actually works, but I had to get the required gnome-packagekit version from updates-testing.
Comment 7 Fedora Update System 2008-12-09 06:35:38 EST
PolicyKit-0.9-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PolicyKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11043
Comment 8 Fedora Update System 2008-12-09 06:38:17 EST
PolicyKit-0.8-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update PolicyKit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11058
Comment 9 Tomas Hoger 2008-12-09 07:07:43 EST
(In reply to comment #6)
> dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A
> security policy in place prevents this sender from sending this message to this
> recipient, see message bus configuration file (rejected message had interface
> "org.fedoraproject.Config.Samba.Backend" member "readSmbConf" error name
> "(unset)" destination ":1.90")

Sound like a s-c-samba bug, unlikely to be directly related to this bug.
Comment 10 Christopher D. Stover 2008-12-09 10:10:16 EST
*** Bug 475122 has been marked as a duplicate of this bug. ***
Comment 11 Tomas Hoger 2008-12-09 11:08:08 EST
(In reply to comment #9)
> Sound like a s-c-samba bug, unlikely to be directly related to this bug.

See bug #475524.
Comment 12 Ian Amess 2008-12-09 14:11:02 EST
Created attachment 326381 [details]
Shows errors during KDE startup

Applied PolicyKit-0.9-4.fc10 from testing repo but still the problem persists. I have attached a copy of .xsession-errors which shows some of the problems encountered.
Comment 13 ggrau 2008-12-10 05:29:54 EST
Installed PolicyKit 0.9-4.fc10 and dbus 1.2.8-1.fc10

'Update System' and 'Add/Remove Software' still shows this Error:

 failed to get a TID: A security policy in place prevents this sender from
sending this message to this recipient, see message bus configuration file
(rejected message had interface "org.freedesktop.PackageKit.Transaction" member
"SetLocale" error name "(unset)" destination "org.freedesktop.PackageKit") (0)
Comment 14 Dan Ziemba 2008-12-10 05:35:46 EST
Have you installed the updated PackageKit as well?
Comment 15 ggrau 2008-12-10 07:16:16 EST
PackageKit was 0.3.11-1 from the update-testing repo. Did not knew that there was anything newer. After installing 0.3.12-1 it works.
Unfortunately gpk-application now stalls, when refreshing the package cache at 'Downloading Groups'. May be some issue because I just updated from Fedora 9 to 10 using yum... 

Thanks for the hint...
Comment 16 Juan 2008-12-10 21:14:27 EST
Works with PackageKit 0.3.11-4, gnome-packagekit 0.3.11-1 and PolicyKit 0.9-4
Thanks a lot!
Comment 17 Nils Philippsen 2008-12-12 05:59:32 EST
*** Bug 476088 has been marked as a duplicate of this bug. ***
Comment 18 Nils Philippsen 2008-12-15 09:02:59 EST
*** Bug 476389 has been marked as a duplicate of this bug. ***
Comment 19 Roger L. Olson 2008-12-15 17:58:28 EST
Updating PolicyKit-0.9-3.fc10 with PolicyKit-0.9-4.fc10 resolved the issue with system-config-services not opening.  Thanks :).
Comment 20 Fedora Update System 2008-12-17 19:39:18 EST
PolicyKit-0.9-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Nils Philippsen 2008-12-18 04:47:42 EST
*** Bug 476939 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.