Bug 476573 - multi-org, shared channels is not allowing users to view details, ISE
multi-org, shared channels is not allowing users to view details, ISE
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeff Ortel
Red Hat Satellite QA List
rhn/software/packages/Details.do?pid=...
:
Depends On: 475365
Blocks: space04 476893
  Show dependency treegraph
 
Reported: 2008-12-15 14:47 EST by Shannon Hughes
Modified: 2009-01-22 11:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 11:38:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2008-12-15 14:47:46 EST
+++ This bug was initially created as a clone of Bug #475365 +++

Description of problem:

we need to modify the verification for a user access to package details. looks like we are joining against rhnAvailableChannels which does not query the trusted orgs to allow access to users of trusted organizations that own the package. 

UserManager class [verify package access] -> query for rhnavailablechannels and rhnchannelpackage

Expected results: 

users of trusted orgs viewing shared channels should have access to the package details.
Comment 1 Jeff Ortel 2008-12-17 11:10:26 EST
After looking at this, it seemed to make sense to update the rhnAvailableChannels view to included shared channels.  Making this change fixes this issue and doesn't appear to have any negative side affects on other pages/functionallity.  

Since this is a schema change, the following schema upgrade scripts need to be run before testing (or reload the schema):

/schema/spacewalk/upgrade/spacewalk-0.3-spacewalk-0.4

122-rhn_channel.pkb
144-rhnSharedChannelTreeView.sql
145-rhnAvailableChannels.sql

Note You need to log in before you can comment on or make changes to this bug.