Bug 476733 - Sender for Web Traceback emails is listed as Spacewalk
Sender for Web Traceback emails is listed as Spacewalk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Steve Salevan
:
: 483040 (view as bug list)
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2008-12-16 15:39 EST by Jeff Browning
Modified: 2009-09-10 14:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Browning 2008-12-16 15:39:43 EST
Description of problem:
Emails generated by Satellite (such as the ISE Web Traceback emails sent to the admin email address) have the Sender listed as Spacewalk.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Register a 530 Sat and put your email as the admin email address
2. Cause an ISE (many ways to do this)
3. Check your email
  
Actual results:
You'll have an email with the traceback in it, but the Sender of that email is still listed as Spacewalk.

Expected results:
The Sender should be listed as Red Hat Network as in previous version of Satellite.

Additional info:
Comment 1 Devan Goodwin 2009-02-05 15:27:31 EST
Tricky one to reproduce reliably but I think I've got it with:

service cobblerd stop
rhn-satellite restart

Fixed in spacewalk by allowing the overriding of web.default_mail_from in rhn.conf: f8341309424df331988febfac84a3d9291853d27

Fixed in satellite by setting satellite-branding up to actually override the setting: 89de94a7015a0fac8fa60cd4140f36d3f22a8aa0

Traceback mail should now appear from: RHN Satellite <dev-null@redhat.com>
Comment 2 Preethi Thomas 2009-02-06 12:06:23 EST
*** Bug 483040 has been marked as a duplicate of this bug. ***
Comment 3 Steve Salevan 2009-02-10 17:34:24 EST
Heh, that's a great way to cause ISEs to fly like the wind.  Verified that ISE messages were tagged with 'RHN Satellite' as the sender.  Moving to VERIFIED.
Comment 4 Milan Zázrivec 2009-08-11 05:19:04 EDT
Verified in stage -> RELEASE_PENDING
Comment 5 Brandon Perkins 2009-09-10 14:53:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.