Bug 476761 - When an agent is non-responsive, the qpid-config CLI utility sees long delay
When an agent is non-responsive, the qpid-config CLI utility sees long delay
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-qmf (Show other bugs)
1.1
All Linux
high Severity high
: 1.1
: ---
Assigned To: Ted Ross
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 18:23 EST by Ted Ross
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-04 10:37:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-12-16 18:23:48 EST
While investigating a related issue (476759) during which there were several QMF agents that were not sending data (or responding to requests), it was discovered that qpid-config took a long time (minutes) to respond.  This is because it is timing out waiting for an agent to answer.

qpid-config needs to be more focused about which agents it communicates with.

Also, the console API needs to detect non-responsive agents and exclude them from broadcasted requests.
Comment 1 Ted Ross 2008-12-17 13:41:03 EST
This is fixed in upstream revision 727462.

The fix was to make qpid-config more defensive.  It now restricts its queries to involve only the agent that is co-resident with the broker-under-management.

This is going to be difficult to positively verify because non-responsive agents occur only intermittently.
Comment 3 Jan Sarenik 2009-01-09 04:52:32 EST
Example scenario:

Ensure qpidd is running (root# service qpidd restart)
On one console, manually start sesame (root# sesame)
On another console, start qpid-config (root# qpid-config)
Back at console #1, press ^Z to suspend the process by shell.
On second console, run qpid-config again
  in version python-qpid-0.3.722953 it is hanging
  in version python-qpid-0.4.732797 it is working*

Tested on RHEL-5.2 and 4.7, both i386 and x86_64.

* qpid-config will work just in case it's internal Python
  syntax is updated to work with older Python versions.
  See Bug 479382 for more info.
Comment 5 errata-xmlrpc 2009-02-04 10:37:12 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0035.html

Note You need to log in before you can comment on or make changes to this bug.