Bug 476777 - Sometims iwlagn (Montevina): Sony Laptop fails to suspend if user doing wireless WEP then WPA association first
Sometims iwlagn (Montevina): Sony Laptop fails to suspend if user doing wirel...
Status: CLOSED DUPLICATE of bug 474699
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acpid (Show other bugs)
5.4
All Linux
low Severity high
: rc
: 5.4
Assigned To: John W. Linville
BaseOS QE
:
Depends On:
Blocks: 480792
  Show dependency treegraph
 
Reported: 2008-12-16 21:41 EST by DongpoLiu
Modified: 2009-04-23 10:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 10:13:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suspend log info (970.01 KB, text/plain)
2008-12-16 21:47 EST, DongpoLiu
no flags Details
wpa log info (1.68 MB, application/octet-stream)
2008-12-16 21:50 EST, DongpoLiu
no flags Details
iwlwifi-linux-2.6.27-9to10.patch (6.97 KB, text/plain)
2009-03-26 06:58 EDT, DongpoLiu
no flags Details

  None (edit)
Description DongpoLiu 2008-12-16 21:41:16 EST
Description of problem:
Montevina Laptop fails to do suspend if user doing wireless WEP then WAP association first.

Version-Release number of selected component (if applicable):
OS: RHEL 5.3 SP5
Kernel:2.6.18-126.el5
WPA-Supplicant: with -dddt is added
NetworkManager: NetworkManager-0.7.0-1.el5

How reproducible:
we can see issue quite frequently.

Steps to Reproduce:
Issue 1)
I get an fatal issue when doing suspend , detailed steps is as follows:
1) get Montevina associted with a WEP64 AP successfully by NetworkManager 
2) then switch to a WAP AP successfully by NetworkManager 
3) click KLaptop to get Sony Montevina Laptop suspend
4) then user will get following info:
Disabling non-boot CPUs
iwlagn: No space for Tx
iwlagn: Error sending REPLY_STATISTICS_CMD: enqueue_hcmd failed: -28
then suspend seems stops, what user can do is to press Power button to get OS
bootup by force.

Issue 2)
Sometimes, on OS boot up, we fails to get Montevina assocaited with a WPA keyed
AP, while we scarcely reproduce such an issue with WEP keyed AP.

Issue 3)
when I get Montevina associated with WPA AP, then go suspend, sometimes I will
get error info as follows:
Dec 16 02:09:36 osve-sony kernel: CPU1 is down
Dec 16 02:09:36 osve-sony kernel: Stopping tasks:
=====================================================<7>wlan0:
deauthenticate(reason=3)
Dec 16 02:09:36 osve-sony kernel:
=============================================<3>iwlagn: Error: Response NULL in
'REPLY_ADD_STA'
Dec 16 02:09:36 osve-sony kernel: ACPI: PCI interrupt for device 0000:06:00.0
disabled.
while we can get Laptop to suspend and wakeup.
  
Actual results:
User can only boot up Laptop by pressing power button by force in case of issue 1

Expected results:


Additional info:
Comment 1 DongpoLiu 2008-12-16 21:47:15 EST
Created attachment 327197 [details]
suspend log info
Comment 2 DongpoLiu 2008-12-16 21:50:45 EST
Created attachment 327200 [details]
wpa log info
Comment 5 John W. Linville 2009-03-19 13:08:07 EDT
Is this still an issue with the -135.el5 (or later) kernels?  They have a patch that I think might pertain to this issue as well.
Comment 6 DongpoLiu 2009-03-20 01:43:15 EDT
one updates: 
1) we can reproduce almost the same defect at upstream Linux 2.6.27 kernel(from http://www.kernel.org/) + RHEL 5.3 OS, 
2) while cannot reproduce this defect at Linux 2.6.28 kernel  + RHEL 5.3 OS , 

I have create a patch between RHEL 2.6.18.128.e15 kernel and Linux 2.6.28 kernel, status is as follows:
1) currently I can get iwlagn readily associated with WAP AP now 
2) and temporarily get IP address, then wlan0 interface down wehn trying to get associated with WEP AP.

I am trying to patch more now....

may this information do some help to you.
Comment 7 DongpoLiu 2009-03-20 01:45:11 EDT
just tried  -135.el5 kernel, this issue can still be reproduced, in addition, iwlagn often fails to get associated with WPA AP.
Comment 8 DongpoLiu 2009-03-26 06:56:10 EDT
Updates:
I installed linux-2.6.27.9.tar.bz2 and linux-2.6.27.10.tar.bz2 (which are from www.kernel.org)into RHEL 5.3 RC2 OS,
with linux-2.6.27.9, we can reproduced this issue, that is we can get iwlwifi associated with WPA-keyed AP, while failed with WEP-keyed AP.

with linux-2.6.27.10, we can get iwlwifi associated with WPA-keyed AP or WEP keyed AP, and do association switch between WPA-keyed AP or WEP keyed AP.

I diffed the mac80211/ieee80211, there is no difference between linux-2.6.27.9 and linux-2.6.27.10.

attached is iwlwifi-linux-2.6.27-9to10.patch, maybe we can find iwlwifi driver root cause in this patch?
Comment 9 DongpoLiu 2009-03-26 06:58:12 EDT
Created attachment 336776 [details]
iwlwifi-linux-2.6.27-9to10.patch
Comment 10 DongpoLiu 2009-03-26 07:02:59 EDT
in addition, by command line way
ifconfig wlan0 up 
iwconfig wlan0 essid xxxx key restricted xxxxxx
dhclient wlan0.

in both linux-2.6.27.9 and linux-2.6.27.10, we find 
1) iwlagn readily associated with WAP AP now 
2) and temporarily get (false) IP address, then wlan0 interface down when trying to get associated with WEP AP.
log is as follows:
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_poll_bit poll_bit(0x00000020, 0x00000100, 0x00000100) - - drivers/net/wireless/iwlwifi/iwl-4965.c 455
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U iwl4965_apm_stop_master stop master
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_set_bit set_bit(0x00000020, 0x00000080) = 0x00000381
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_set_bit set_bit(0x00000024, 0x00000004) = 0x080033D4
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_poll_bit poll_bit(0x00000020, 0x00000001, 0x00000001) - - drivers/net/wireless/iwlwifi/iwl-4965.c 501
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_grab_nic_access grabbing nic access - drivers/net/wireless/iwlwifi/iwl-4965.c 508
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U __iwl_release_nic_access releasing nic access - drivers/net/wireless/iwlwifi/iwl-4965.c 521
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U iwl_clear_free_frames 0 frames on pre-allocated heap on clear.
Mar 26 18:56:32 osve-sr kernel: iwlagn 0000:04:00.0: PCI INT A disabled
Mar 26 18:56:32 osve-sr kernel: ieee80211 phy0: U iwl4965_mac_stop leave

so to fix this issue, we need update both mac80211 even ieee80211? the efforts between 2.6.18 and 2.6.27.10 kernel is big.
Comment 11 RHEL Product and Program Management 2009-03-26 13:06:34 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 DongpoLiu 2009-03-26 22:06:55 EDT
sorry, comment 8 to 10 is for defect 474699. pls skip my comments here.
Comment 13 John Villalovos 2009-04-14 13:39:26 EDT
Clearing needinfo flag
Comment 14 DongpoLiu 2009-04-23 01:52:10 EDT
(In reply to comment #0)
> Description of problem:
> Montevina Laptop fails to do suspend if user doing wireless WEP then WAP
> association first.
> 
> Version-Release number of selected component (if applicable):
> OS: RHEL 5.3 SP5
> Kernel:2.6.18-126.el5
> WPA-Supplicant: with -dddt is added
> NetworkManager: NetworkManager-0.7.0-1.el5
> 
> How reproducible:
> we can see issue quite frequently.
> 
> Steps to Reproduce:
> Issue 1)
> I get an fatal issue when doing suspend , detailed steps is as follows:
> 1) get Montevina associted with a WEP64 AP successfully by NetworkManager 
> 2) then switch to a WAP AP successfully by NetworkManager 
> 3) click KLaptop to get Sony Montevina Laptop suspend
> 4) then user will get following info:
> Disabling non-boot CPUs
> iwlagn: No space for Tx
> iwlagn: Error sending REPLY_STATISTICS_CMD: enqueue_hcmd failed: -28
> then suspend seems stops, what user can do is to press Power button to get OS
> bootup by force.
I can not reproduce this issue now at 2.6.18-140.el5 kernel.
 
> Issue 2)
> Sometimes, on OS boot up, we fails to get Montevina assocaited with a WPA keyed
> AP, while we scarcely reproduce such an issue with WEP keyed AP.
I can not reproduce this issue now at 2.6.18-140.el5 kernel.

> Issue 3)
> when I get Montevina associated with WPA AP, then go suspend, sometimes I will
> get error info as follows:
> Dec 16 02:09:36 osve-sony kernel: CPU1 is down
> Dec 16 02:09:36 osve-sony kernel: Stopping tasks:
> =====================================================<7>wlan0:
> deauthenticate(reason=3)
> Dec 16 02:09:36 osve-sony kernel:
> =============================================<3>iwlagn: Error: Response NULL in
> 'REPLY_ADD_STA'
> Dec 16 02:09:36 osve-sony kernel: ACPI: PCI interrupt for device 0000:06:00.0
> disabled.
> while we can get Laptop to suspend and wakeup.
I can not reproduce this issue now at 2.6.18-140.el5 kernel.

> Actual results:
> User can only boot up Laptop by pressing power button by force in case of issue
> 1
> 
> Expected results:
> 
> 
> Additional info:  

all above tests are done at kernel-2.6.18-140.el5.x86_64.
Comment 15 John W. Linville 2009-04-23 10:13:30 EDT
This was fixed by the same patches as 474699, so marking as Duplicate for accounting purposes...

*** This bug has been marked as a duplicate of bug 474699 ***

Note You need to log in before you can comment on or make changes to this bug.