Bug 476785 - cursor goes wonky after user-switching
cursor goes wonky after user-switching
Status: CLOSED DUPLICATE of bug 473368
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 23:30 EST by Roland McGrath
Modified: 2009-05-19 07:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 18:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2008-12-16 23:30:44 EST
Description of problem:

When using fast user-switching from the initial session on tty1, going back with user-switch menus for Ctrl-Alt-F1 the X server's cursor is all wrong.
It looks like it's drawing a 64x64 rectangle of random bits or something.

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.9.0-61.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386
kernel-2.6.27.7-134.fc10.i686
gdm-user-switch-applet-2.24.1-2.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1.log in from gdm on tty1
2.hit the upper-right button to switch users
3.switch back to tty1
  
Actual results:

Wonky cursor display.

Expected results:

Cursor display unchanged by switching and switching back.

Additional info:

bug 476783 attachments have the same xorg.conf and server log (first one) for the setup in this case.
Comment 1 Matej Cepl 2008-12-17 18:33:25 EST

*** This bug has been marked as a duplicate of bug 473368 ***

Note You need to log in before you can comment on or make changes to this bug.