Bug 476804 - ypbind init script returns 0 for a successful start command
ypbind init script returns 0 for a successful start command
Status: CLOSED DUPLICATE of bug 467861
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 03:56 EST by Dan Bode
Modified: 2008-12-17 04:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 04:16:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Bode 2008-12-17 03:56:49 EST
Description of problem:

init script for ypbind returns 1 on success

Version-Release number of selected component (if applicable):

# Version:      @(#) /etc/init.d/ypbind.init 1.3

How reproducible:

stop and start the service with the init script.

Steps to Reproduce:
1./etc/init.d/ypbind stop
2./etc/init.d/ypbind start
3.echo $?
  
Actual results:

1

Expected results:

0

Additional info:

bug is caused by the following lines

    147         start
    148         [ $? -eq 100 ] && stop
    ...
    166 esac
    167
    168 exit $?

if the return code of start is zero, then line 148 will change the return used for exit to 1
Comment 1 Vitezslav Crhonek 2008-12-17 04:16:58 EST
It's already fixed in Rawhide (ypbind-1.20.4-10.fc11).

BTW I suppose that you have opened #476803 by mistake and should be closed, right?;)

*** This bug has been marked as a duplicate of bug 467861 ***
Comment 2 Dan Bode 2008-12-17 04:35:35 EST
yes, the previous bug was a mistake.

Note You need to log in before you can comment on or make changes to this bug.