Bug 476939 - system-config-services does not start
system-config-services does not start
Status: CLOSED DUPLICATE of bug 475200
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 23:50 EST by Matt Castelein
Modified: 2008-12-18 04:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 04:47:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Castelein 2008-12-17 23:50:20 EST
Description of problem:
Choosing System->Administration->Services from gnome menu produces "Starting Services" button on taskbar, which then disappears.  Running from command line produced:
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 945, in <module>
    GUI (use_dbus = use_dbus).run ()
  File "/usr/bin/system-config-services", line 900, in __init__
    self.serviceherders.append (cls (bus = self._bus))
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 53, in __init__
    for service_name in self.list_services ():
  File "/usr/lib/python2.5/site-packages/slip/dbus/polkit.py", line 48, in enable_proxy_wrapper
    return func (*p, **k)
  File "/usr/lib/python2.5/site-packages/scservices/dbus/proxy/serviceherders.py", line 66, in list_services
    return self.dbus_object.list_services (dbus_interface = "org.fedoraproject.Config.Services.ServiceHerder")
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.PolicyKit" member "IsSystemBusNameAuthorized" error name "(unset)" destination ":1.73")

Version-Release number of selected component (if applicable):
system-config-services-0.99.28-3.fc10.noarch

Additional info:
Tried "setenforce 0" with same result.
Comment 1 Andre Robatino 2008-12-18 00:10:29 EST
This is a duplicate of bug #475200 and is fixed by the latest batch of updates.  In the meantime, you can run it from the command line as root after "su -" (not just "su").
Comment 2 Nils Philippsen 2008-12-18 04:47:42 EST

*** This bug has been marked as a duplicate of bug 475200 ***

Note You need to log in before you can comment on or make changes to this bug.