Bug 476944 - Firefox leaving traces of previous content
Firefox leaving traces of previous content
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
10
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 477861 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 02:51 EST by Roozbeh Pournader
Modified: 2009-01-23 09:49 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-23 09:49:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log (80.83 KB, text/plain)
2008-12-29 14:32 EST, william hanlon
no flags Details

  None (edit)
Description Roozbeh Pournader 2008-12-18 02:51:19 EST
Description of problem:
Firefox leaves traces of its previous content on the screen.

Version-Release number of selected component (if applicable):
firefox-3.0.4-1.fc10.i386

How reproducible:
Always, also on machines with different hardware

Steps to Reproduce:
1. Go to http://planet.gnome.org/
2. Wait until the whole page loads
3. Press the "End" button on your keyboard
4. DON'T TOUCH ANYTHING
 
Actual results:
Some of the text from the top of the page is displayed at the bottom, together with its light background. It goes away when you switch to another application and come back.

Expected results:
Only the stuff from the bottom of the page (dark background) should be displayed.
Comment 1 Martin Stransky 2008-12-18 04:54:14 EST
Looks more like X problem than the firefox one...
Comment 2 Matěj Cepl 2008-12-18 19:50:48 EST
Well, Martin, I can reproduce it on my notebook with intel driver, and no other program seems to do things like this.

Reporter, would you please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to this bug report as individual uncompressed file attachments using the bugzilla file attachment link below?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Behdad Esfahbod 2008-12-18 20:28:38 EST
Guys, I've seen it with ati, and with intel.
Comment 4 Karl Tomlinson 2008-12-18 21:49:16 EST
It's as if X windows are not being moved correctly, which is more likely a Mozilla bug

https://bugzilla.mozilla.org/show_bug.cgi?id=470358
Comment 5 william hanlon 2008-12-29 14:32:00 EST
Created attachment 327928 [details]
X server log

I'm seeing the same problem with firefox but also with xterm and rxvt as well. Firefox is the most egregious offender though. When you mouse over links sometimes they are shown twice (one below the other); when scrolling down pages the text is shown twice, etc. When I move xterms and rxvts, sometimes the borders are not redrawn correctly when the move is completed, or the lines around the scrollbar are drawn twice (one next to the other). I've included my Xorg server log, but it looks like in Fedora 10, xorg.conf is now optional since I don't have one (at least not in /etc/X11 anymore).
Comment 6 william hanlon 2008-12-29 14:54:52 EST
I can't figure out what causes the display problem with firefox, but when it does happen I've noticed that causing the firefox window to LOSE focus, causes firefox to update and it then looks correct. So for instance, do the procedure described in the problem description, then move the mouse to another window and change focus. The firefox window will now look OK.

This does not fix the problem for messed up rxvt windows though.

I regularly use fluxbox, but I seem the same problem using gnome.
Comment 7 Matěj Cepl 2009-01-09 12:41:15 EST
*** Bug 477861 has been marked as a duplicate of this bug. ***
Comment 8 william hanlon 2009-01-19 15:49:27 EST
I've made a few more observations concerning this problem:

1.) Turning off smooth scrolling (Edit > Preferences > Advanced) greatly reduces the problem, but doesn't completely eliminate it.

2.) Grabbing the scroll bar with the mouse to move (as opposed to using the mouse wheel) through pages also greatly reduces the problem (this is with smooth scrolling on).

3.) I'm running the same versions of Fedora 10 and Firefox on two different machines, one using the r128 xorg driver and the other using the intel driver. I have no problems at all using the r128 driver, all problems I've reported are on the machine running the intel driver.
Comment 9 Karl Tomlinson 2009-01-19 22:54:24 EST
(In reply to comment #8)
> I have no problems at all using the r128 driver

Even no problem with the Steps to Reproduce in comment 0?
I can reproduce with the radeon driver and AccelMethod EXA or XAA or NoAccel.

(The xterm and rxvt issues that you reported in comment 5 may be a different issue.)
Comment 10 william hanlon 2009-01-20 00:36:33 EST
(In reply to comment #9)
> (In reply to comment #8)
> > I have no problems at all using the r128 driver
> 
> Even no problem with the Steps to Reproduce in comment 0?
> I can reproduce with the radeon driver and AccelMethod EXA or XAA or NoAccel.

Hmmm. No, you're right, when I try the test from comment 0, the page is messed up. The machine running the r128 driver is much, much better in all other respects compared to the issues I've provided for the intel driver. Firefox on the machine using the intel driver is borderline unusable. Every small movement of a web page requires me to move the mouse out of the window to force loss of focus and a refresh of firefox.

> (The xterm and rxvt issues that you reported in comment 5 may be a different
> issue.)

Yes, I think the xterm and rxvt issue should be ignored in this bug. I turned off opaque window moving and that "resolved" the issue for me.
Comment 11 Martin Stransky 2009-01-20 03:32:01 EST
Fully reproducible with nvidia driver...taking this one.
Comment 13 Martin Stransky 2009-01-23 09:49:04 EST
closing as upstream...

Note You need to log in before you can comment on or make changes to this bug.