Bug 477075 - yum-complete-transaction: global name 'os' is not defined
yum-complete-transaction: global name 'os' is not defined
Status: CLOSED DUPLICATE of bug 470458
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 18:18 EST by Andrew Bartlett
Modified: 2014-01-21 18:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-18 22:19:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Bartlett 2008-12-18 18:18:51 EST
Description of problem:
At the end of yum-complete-transaction the script aborts with a python syntax error


Version-Release number of selected component (if applicable):
rpm -q python yum
python-2.6-2.fc11.x86_64
yum-3.2.20-7.fc11.noarch


How reproducible:
Every time

Steps to Reproduce:
1. Intrrupt a yum transaction
2. Run 'yum-complete-transaction'
3. wait for transaction to complete
  
Actual results:
Cleaning up completed transaction file
Traceback (most recent call last):
  File "/usr/sbin/yum-complete-transaction", line 208, in <module>
    util = YumCompleteTransaction()
  File "/usr/sbin/yum-complete-transaction", line 115, in __init__
    self.main()
  File "/usr/sbin/yum-complete-transaction", line 189, in main
    self.clean_up_ts_files(timestamp, self.conf.persistdir)
  File "/usr/sbin/yum-complete-transaction", line 123, in clean_up_ts_files
    if os.path.exists(f):
NameError: global name 'os' is not defined


Expected results:
yum-complete-tranaction should complete

Additional info:
Comment 1 seth vidal 2008-12-18 22:19:33 EST

*** This bug has been marked as a duplicate of bug 470458 ***

Note You need to log in before you can comment on or make changes to this bug.