This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477097 - improper " preupgrade.PUError: /boot is on unbootable RAID level 'raid10' "
improper " preupgrade.PUError: /boot is on unbootable RAID level 'raid10' "
Status: CLOSED DUPLICATE of bug 473103
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-18 21:27 EST by Davide Repetto
Modified: 2014-01-21 18:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 02:02:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Davide Repetto 2008-12-18 21:27:30 EST
Description of problem:
=======================

Upgrading from f9 to f10 preupgrade-cli terminates with the following error:
(while the gui version just hangs without telling)
I think that this is improper, because /boot is not actually on raid10

====== snip =======
Generating metadata for preupgrade repo
1053/1053 - preupgrade/packages/fakeroot-1.9.7-18.fc10.i386.rpm                 mmpm0.i386.rpm
Saving Primary metadata
Saving file lists metadata
Saving other metadata
Generating sqlite DBs
Sqlite DBs complete
Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-cli.py", line 284, in <module>
    pu.main(myrelease)
  File "/usr/share/preupgrade/preupgrade-cli.py", line 251, in main
    repopath = preupgrade.bootpath_to_anacondapath(cachedir, UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 197, in bootpath_to_anacondapath
    raise PUError, "/boot is on unbootable RAID level '%s'" % raid['level']
preupgrade.PUError: /boot is on unbootable RAID level 'raid10'
===================


Version-Release number of selected component (if applicable):
=============================================================
preupgrade-1.0.0-1.fc9.noarch



Additional info:
================


Relevant section of grub.conf
=============================

splashimage=(hd0,0)/grub/splash.xpm.gz

title Fedora (2.6.27.7-53.fc9.i686.PAE)
        root (hd0,0)
        kernel /vmlinuz-2.6.27.7-53.fc9.i686.PAE ro root=UUID=40fbf175-a6d4-494d-a912-14781118e48b


[root@cp ~]# more /proc/mdstat
==============================

Personalities : [raid10] [raid6] [raid5] [raid4] [raid1]
md2 : active raid10 sda3[0] sdb3[1]
      441586176 blocks 256K chunks 2 far-copies [2/2] [UU]

md0 : active raid1 sda1[0] sdb1[1]
      200704 blocks [2/2] [UU]

md1 : active raid10 sda2[0] sdb2[1]
      46596096 blocks 256K chunks 2 far-copies [2/2] [UU]



[root@cp ~]# df -h
==================

Filesystem            Size  Used Avail Use% Mounted on
/dev/md1               44G  9,2G   33G  23% /
/dev/md0              190M  156M   25M  87% /boot
/dev/md2              415G  117G  277G  30% /work
tmpfs                 2,0G   48K  2,0G   1% /dev/shm
/dev/sdd1             280G  169G  112G  61% /media/HD SECURITY
/dev/sdc1             459G  269G  167G  62% /media/disk



[root@cp ~]# mount
==================

/dev/md1 on / type ext4dev (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/md0 on /boot type ext3 (rw)
/dev/md2 on /work type ext4dev (rw)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
gvfs-fuse-daemon on /home/cp/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=cp)
/dev/sdd1 on /media/HD SECURITY type vfat (rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=500)
/dev/sdc1 on /media/disk type ext4dev (rw,nosuid,nodev,uhelper=hal)



[root@cp ~]# blkid
==================

/dev/sda1: UUID="005ba8e3-1d1c-8b92-f85e-a61e03819c49" TYPE="mdraid"
/dev/sdb1: UUID="005ba8e3-1d1c-8b92-f85e-a61e03819c49" TYPE="mdraid"
/dev/sdb2: UUID="ddb642af-713c-5c96-36f3-df241c7e399f" TYPE="mdraid"
/dev/md0: LABEL="boot" UUID="9dbdaf88-2a31-4005-b298-46a005d0ac6a" SEC_TYPE="ext2" TYPE="ext3"
/dev/md1: LABEL="/" UUID="40fbf175-a6d4-494d-a912-14781118e48b" TYPE="ext4"
/dev/sdc1: UUID="074c46fb-f1a2-4f28-8e7d-2b796ee75570" TYPE="ext4dev"
/dev/sdb3: UUID="89efcc47-d427-0ef5-7318-e91ff15888bb" TYPE="mdraid"
/dev/sdc3: UUID="729a48c0-9a5d-6630-130d-f6bbc4449968" TYPE="mdraid"
/dev/sda2: UUID="ddb642af-713c-5c96-36f3-df241c7e399f" TYPE="mdraid"
/dev/sda3: UUID="89efcc47-d427-0ef5-7318-e91ff15888bb" TYPE="mdraid"
/dev/md2: LABEL="work" UUID="47de56e9-128d-40e3-9a4f-0894b47a571b" TYPE="ext4dev"
/dev/sdd1: LABEL="HD SECURITY" UUID="6853-5BA9" TYPE="vfat"



[root@cp ~]# fdisk -l
=====================

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcabd468c

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1          25      200781   fd  Linux raid autodetect
/dev/sda2              26        5826    46596532+  fd  Linux raid autodetect
/dev/sda3            5827       60801   441586687+  fd  Linux raid autodetect

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00095b35

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1          25      200781   fd  Linux raid autodetect
/dev/sdb2              26        5826    46596532+  fd  Linux raid autodetect
/dev/sdb3            5827       60801   441586687+  fd  Linux raid autodetect

Disk /dev/sdc: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x4b1b3185

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1               1       60801   488384001   83  Linux

Disk /dev/md1: 47.7 GB, 47714402304 bytes
2 heads, 4 sectors/track, 11649024 cylinders
Units = cylinders of 8 * 512 = 4096 bytes
Disk identifier: 0x00000000

Disk /dev/md1 doesn't contain a valid partition table

Disk /dev/md0: 205 MB, 205520896 bytes
2 heads, 4 sectors/track, 50176 cylinders
Units = cylinders of 8 * 512 = 4096 bytes
Disk identifier: 0x00000000

Disk /dev/md0 doesn't contain a valid partition table

Disk /dev/md2: 452.1 GB, 452184244224 bytes
2 heads, 4 sectors/track, 110396544 cylinders
Units = cylinders of 8 * 512 = 4096 bytes
Disk identifier: 0x00000000

Disk /dev/md2 doesn't contain a valid partition table

Disk /dev/sdd: 300.0 GB, 300090728448 bytes
255 heads, 63 sectors/track, 36483 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x12345678

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *           1       36483   293049666    c  W95 FAT32 (LBA)
Comment 1 Will Woods 2008-12-19 02:02:18 EST
This is fixed in preupgrade-1.0.1, which is in updates-testing.

*** This bug has been marked as a duplicate of bug 473103 ***

Note You need to log in before you can comment on or make changes to this bug.