Bug 473103 - preupgrade-1.0.0-1 refuses to upgrade raid0/raid5 root
Summary: preupgrade-1.0.0-1 refuses to upgrade raid0/raid5 root
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 474888 477097 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-11-26 15:21 UTC by Neal Becker
Modified: 2014-01-21 23:07 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-07 09:08:29 UTC


Attachments (Terms of Use)

Description Neal Becker 2008-11-26 15:21:45 UTC
Description of problem:
vailable disk space for /var/cache/yum/preupgrade: 120.5GB                                           
Upgrade requires 500.0MB                                                                              
Available disk space for /usr: 117.6GB                                                                
Generating metadata for preupgrade repo                                                               
Traceback (most recent call last):                                                                    
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 237, in on_assistant_apply                     
    self._do_main()                                                                                   
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 256, in _do_main                               
    self.main_preupgrade()                                                                            
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 531, in main_preupgrade                        
    repopath=preupgrade.bootpath_to_anacondapath(cachedir,UUID=True)                                  
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 197, in bootpath_to_anacondapath                                                                                                     
    raise PUError, "/boot is on unbootable RAID level '%s'" % raid['level']                           
preupgrade.PUError: /boot is on unbootable RAID level 'raid0'  

But that's not true!  /boot is on it's own partition:
 mount
/dev/md0 on / type ext3 (rw,noatime)
proc on /proc type proc (rw)        
sysfs on /sys type sysfs (rw)       
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw,noatime)         
tmpfs on /dev/shm type tmpfs (rw)                 
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
fusectl on /sys/fs/fuse/connections type fusectl (rw) 

Version-Release number of selected component (if applicable):

preupgrade-1.0.0-1.fc9.noarch                                                                         

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tony Nolly 2008-11-27 12:12:23 UTC
Description of problem:

Traceback (most recent call last):
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 237, in on_assistant_apply
    self._do_main()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 256, in _do_main
    self.main_preupgrade()
  File "/usr/share/preupgrade/preupgrade-gtk.py", line 531, in main_preupgrade
    repopath=preupgrade.bootpath_to_anacondapath(cachedir,UUID=True)
  File "/usr/lib/python2.5/site-packages/preupgrade/__init__.py", line 197, in bootpath_to_anacondapath
    raise PUError, "/boot is on unbootable RAID level '%s'" % raid['level']
preupgrade.PUError: /boot is on unbootable RAID level 'raid5'


/boot on my system is on raid 5 partition, but is bootable from the mbr!



Version-Release number of selected component (if applicable):

preupgrade-1.0.0-1.fc9.noarch

Comment 2 Will Woods 2008-11-27 22:49:41 UTC
Yeah, this is a bug in preupgrade-1.0.0-1 - it will refuse to upgrade systems where the root partition is raid0 or raid5. A fix will be available soon.

Comment 3 Will Woods 2008-12-05 23:20:32 UTC
*** Bug 474888 has been marked as a duplicate of this bug. ***

Comment 4 Jack Tanner 2008-12-15 05:41:05 UTC
Dupe of bug 444497 ?

Comment 5 Will Woods 2008-12-15 17:11:39 UTC
(In reply to comment #4)
> Dupe of bug 444497 ?

No - Similar symptom, completely different cause.

Comment 6 Will Woods 2008-12-15 22:30:45 UTC
Built a fixed preupgrade-1.0.1 package, update will be available soon.

http://koji.fedoraproject.org/koji/buildinfo?buildID=73594

If possible, please install and test that build of preupgrade.

Comment 7 Fedora Update System 2008-12-16 22:35:35 UTC
preupgrade-1.0.1-1.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc8

Comment 8 Fedora Update System 2008-12-16 22:38:28 UTC
preupgrade-1.0.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc10

Comment 9 Fedora Update System 2008-12-16 22:38:28 UTC
preupgrade-1.0.1-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/preupgrade-1.0.1-1.fc9

Comment 10 Christof Damian 2008-12-17 08:18:45 UTC
I tried a fc9 -> f10 upgrade with a raid1 boot and raid5 root and it worked for me. That was with the version from koji.

Comment 11 Will Woods 2008-12-19 07:02:18 UTC
*** Bug 477097 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2008-12-21 08:22:52 UTC
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-11587

Comment 13 Fedora Update System 2008-12-21 08:38:08 UTC
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-11540

Comment 14 Fedora Update System 2008-12-21 08:45:28 UTC
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update preupgrade'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11437

Comment 15 Fedora Update System 2009-01-07 09:07:34 UTC
preupgrade-1.0.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2009-01-07 09:08:13 UTC
preupgrade-1.0.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2009-01-07 09:23:58 UTC
preupgrade-1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Serge Pavlovsky 2009-03-28 17:27:05 UTC
i have /boot on /dev/mapper/isw_cfidaabedc_Volume0p2 (software raid0)
and preupgrade-1.0.1-1.fc9.noarch doesnt work


Note You need to log in before you can comment on or make changes to this bug.