Bug 477193 - Remove kitchensync temporarily from distribution
Remove kitchensync temporarily from distribution
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 10:38 EST by Juha Tuomala
Modified: 2009-02-19 06:42 EST (History)
7 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juha Tuomala 2008-12-19 10:38:05 EST
Description of problem:
Menus and default installations ship kitchensync that 
is known to be broken and just confuses users.

It cannot be fixed until the underlying engine is fixed
and that's work in progress, but takes time.

When problems are fixed, new kitchensync must be recompiled 
anyway so there is no reason to keep it visible to users if 
kdepim package is touched for some other reason.
Comment 1 Kevin Kofler 2008-12-19 11:24:50 EST
I'll try to see for myself how badly broken this really is.

I'm not too happy about removing apps in an update. If this entirely useless (i.e. of the "calculator crashes when computing 2+3" type), I can see why we would want to remove it, but if it's just buggy, it's better than nothing.
Comment 2 Kevin Kofler 2008-12-19 11:31:46 EST
CCing Andreas Bierfert, the libopensync maintainer, to see what he has to say about this.
Comment 3 Kevin Kofler 2008-12-19 11:35:26 EST
I'll also add that the version in F10 is most likely less buggy than what we shipped in F9, which was a version of kdepim 3.5 patched for libopensync 0.36 with code from an experimental work branch.

But I'm not sure what to do with KitchenSync when we'll want to upgrade to kdepim 4.2, as KitchenSync is disabled in kdepim 4.2 and the code that is there requires at least libopensync 0.38.
Comment 4 Kevin Kofler 2009-01-24 12:34:48 EST
So the status is that KitchenSync is just broken beyond repair, the code currently in F10 (KDE 4.1) is a dead end using the old libopensync 0.36 API and the showstoppers in it (see also bug 478334 and bug 478337) will most likely never be fixed in that codebase.

In KDE 4.2, the code has been changed a lot to use libopensync >= 0.38. But unfortunately:
* 0.38 is still a development snapshot (as 0.36 was), 0.40 is still not ready.
* We don't have 0.38 in Fedora (not even Rawhide) because it is missing so many plugins. It's also an ABI-incompatible update which would mean pushing a huge grouped update with libopensync 0.38 and all its plugins to F10.
* KitchenSync is disabled in KDE 4.2 because the ported code is not ready, nor is libopensync itself.
So there's no way we can ship that code in Fedora in its current state.

Thus the only option if we wanted to continue shipping KitchenSync would be to revert to the old version from KDE 4.1, but that would mean shipping buggy code forever. Thus, we are planning to drop KitchenSync in the 4.2.0 update (and the current 4.2 packages already don't have it). So I'm putting this on the KDE42 tracker as one of the bugs "fixed" by 4.2.
Comment 5 Rex Dieter 2009-01-27 12:48:45 EST
From our kde-sig meeting this morning, looks like the plan forward is to honor this request to remove kitchensync until both opensync/kdepim upstreams can better/properly support it.
Comment 6 Ngo Than 2009-01-28 10:51:50 EST
it's removed in kdepim-4.2.0-2
Comment 7 Juha Tuomala 2009-02-04 04:03:14 EST
Thanks for taking care of this.

The next logical question is, could we also drop the libopensync too?

It's not an application and dropping such library could of course cause
headache for some developer using it in non-fedora-shipped software but
then again that point of time when that developer snapshot was taken, 
has gone long time ago. And it's broken, never was meant to be working.

I've been compiling my own pkgs from trunk and broken existing libopensync
just needs to be removed for testing and it's useless anyway.
Comment 8 Kevin Kofler 2009-02-04 04:29:40 EST
No, we can't. It is impossible to remove a package from a released distribution. KitchenSync was only removable because it was part of kdepim.
Comment 9 Fedora Update System 2009-02-04 21:26:31 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 10 Fedora Update System 2009-02-06 00:23:42 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 11 Fedora Update System 2009-02-07 17:20:22 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387

Note You need to log in before you can comment on or make changes to this bug.