Bug 478337 - kitchensync crashes upon sync-start when kdepim member of sync-group
kitchensync crashes upon sync-start when kdepim member of sync-group
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 08:09 EST by Stefan Neufeind
Modified: 2009-01-24 12:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-24 12:30:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2008-12-28 08:09:23 EST
Had a group which included a syncml-client (mobile phone) and file. Worked like a charme (after manually configuring it properly with msynctool on console). Having added "kdepim" as a third member on sync-start kitchensync now segfaults.

(Trying to sync from commandline with msynctool for the same three-member-group works, however Kontact shows no entries in the address-book.)
Comment 1 Kevin Kofler 2008-12-28 13:15:28 EST
Unfortunately KitchenSync is in a pretty broken state (as is the underlying libopensync framework), and upstream is dropping it in 4.2 because it is still not ready. I'm not sure what to best do about this. See also bug 477193 which suggests dropping it entirely.
Comment 2 Kevin Kofler 2009-01-24 12:30:38 EST
Unfortunately, KitchenSync is just broken beyond repair, the code currently in F10 (KDE 4.1) is a dead end using the old libopensync 0.36 API, your 2 bugs and several other showstoppers will never be fixed in that codebase.

In KDE 4.2, the code has been changed a lot to use libopensync >= 0.38. But unfortunately:
* 0.38 is still a development snapshot (as 0.36 was), 0.40 is still not ready.
* We don't have 0.38 in Fedora (not even Rawhide) because it is missing so many plugins. It's also an ABI-incompatible update which would mean pushing a huge grouped update with libopensync 0.38 and all its plugins to F10.
* KitchenSync is disabled in KDE 4.2 because the ported code is not ready, nor is libopensync itself.
So there's no way we can ship that code in Fedora in its current state.

Thus the only option if we wanted to continue shipping KitchenSync would be to revert to the old version from KDE 4.1, but that would mean shipping buggy code forever. Thus, we are planning to drop KitchenSync in the 4.2.0 update.

Andreas, any comments/suggestions?

Note You need to log in before you can comment on or make changes to this bug.