Bug 477229 - --queryformat: shorts are not numbers (cannot query file permissions)
--queryformat: shorts are not numbers (cannot query file permissions)
Status: CLOSED DUPLICATE of bug 471820
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 13:46 EST by Patrick Monnerat
Modified: 2008-12-19 13:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-19 13:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Monnerat 2008-12-19 13:46:54 EST
Description of problem:
Trying to get a package file's permissions is unsuccessful.


Version-Release number of selected component (if applicable):
rpm-4.6.0-0.rc1.8.i386

How reproducible:
Always

Steps to Reproduce:
1. Issue command "rpm -q --qf '[%{FILENAMES} %{FILEMODES:perms}\n]' rpm"
  
Actual results:
/bin/rpm (not a number)
/etc/cron.daily/rpm (not a number)
/etc/logrotate.d/rpm (not a number)
/etc/rpm (not a number)
/usr/bin/rpm2cpio (not a number)
/usr/bin/rpmdb (not a number)
 .
 .
 .

Expected results:
On each line, the file permissions instead of (not a number)

Additional info:
This seems related to the 'h' (short) data type. i.e.: %{FILEMODES:hex} and %{FILERDEVS:hex} are also displayed as (not a number)
Comment 1 Patrick Monnerat 2008-12-19 13:53:18 EST
Seems duplicate: sorry

*** This bug has been marked as a duplicate of bug 471820 ***

Note You need to log in before you can comment on or make changes to this bug.