Bug 471820 - rpm --setperms does not work
rpm --setperms does not work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 476727 477229 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 17:41 EST by Gordon Messmer
Modified: 2009-01-07 04:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:21:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2008-11-16 17:41:26 EST
Description of problem:
When attempting to use "rpm --setperms", I get an error like:

sh: line 1: syntax error near unexpected token ')'
sh: line 1: `[ -L '/usr/share/X11' ] || chmod t a number) '/usr/share/X11''

It looks like "chmod %7.7{FILEMODES:octal}" in /usr/lib/rpm/rpmpopt-4.6.0-rc1 evaluates to "chmod (not a number)"


Version-Release number of selected component (if applicable):
rpm-4.6.0-0.rc1.7.i386
Comment 1 Panu Matilainen 2008-11-17 03:47:14 EST
Hum, indeed - this is actually a generic issue with format specifiers on numeric types other than 32bit integers, gone unnoticed as most of the numeric data in rpm is 32 bit integers. Will fix, thanks for reporting.
Comment 2 Panu Matilainen 2008-11-17 06:59:57 EST
Fixed upstream
Comment 3 Bug Zapper 2008-11-26 00:29:33 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Panu Matilainen 2008-11-29 12:47:12 EST
..and in rawhide now, will push as update after a bit of rawhide-soaktime.
Comment 5 Fedora Update System 2008-12-12 14:14:32 EST
rpm-4.6.0-0.rc3.1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rpm-4.6.0-0.rc3.1.fc10
Comment 6 Panu Matilainen 2008-12-17 01:40:17 EST
*** Bug 476727 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2008-12-17 19:34:35 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rpm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11332
Comment 8 Patrick Monnerat 2008-12-19 13:53:18 EST
*** Bug 477229 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2009-01-07 04:20:35 EST
rpm-4.6.0-0.rc3.1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.