Bug 477323 - drm: 845G: Kernel crash, [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 4408 emitted: 4411
drm: 845G: Kernel crash, [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 4408 emitt...
Status: CLOSED DUPLICATE of bug 478000
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 477510
  Show dependency treegraph
 
Reported: 2008-12-20 10:43 EST by Lubomir Rintel
Modified: 2009-09-20 05:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-20 05:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg from i915-related kernel crash (38.80 KB, text/x-log)
2008-12-20 10:43 EST, Lubomir Rintel
no flags Details
X.org log (65.55 KB, text/x-log)
2008-12-20 10:58 EST, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2008-12-20 10:43:08 EST
Created attachment 327538 [details]
Full dmesg from i915-related kernel crash

Soon after starting X11 in Fedora 11, system hangs (exact times at which it happens vary from 1 to 20 seconds after X server start). It may be worth noting that subtle image dissorts are visible.

My graphics hardware is 8086:2562 (rev 01).

At the time of hang, the following appears in kernel log (full dmesg will be attached separately):

Dec 20 16:10:59 [drm] Initialized i915 1.6.0 20080730 on minor 0 
Dec 20 16:12:04 [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 4408 emitted: 4411
Dec 20 16:12:20 last message repeated 4 times
Dec 20 16:12:23 BUG: unable to handle kernel 
Dec 20 16:12:23 NULL pointer dereference
Dec 20 16:12:23  at 00000060 
Dec 20 16:12:23 IP: 
Dec 20 16:12:23  [<f8bdd072>] :i915:i915_driver_irq_handler+0x1d/0x1cf
...

System became unresponsive (to numlock presses) around 16:12:00.
Comment 1 Lubomir Rintel 2008-12-20 10:58:36 EST
Created attachment 327540 [details]
X.org log

Attaching the X.org log, and some more information.

The name of the graphics adapter is:
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)

Relevant package version are:
xorg-x11-drv-i810-2.5.0-4.fc10.i386
xorg-x11-server-Xorg-1.5.3-6.fc10.i386

Relevant part of xorg.conf (It's pretty minimal, anaconda-generated):
Section "Device"
        Identifier  "Videocard0"
        Driver      "intel"
EndSection
Comment 2 Lubomir Rintel 2008-12-21 07:06:49 EST
So the x11 freeze seems not to be a kernel problem -- it happens also without i915 and drm modules loaded, will clone this report for xorg-x11-drv-i810

The symptoms seem to be very same as described here.
http://forums.fedoraforum.org/showthread.php?t=206988

1.) With F9 (gold) live CD everything works fine, even desktop effects.
2.) F10 with xorg-x11-drv-i810 works from F9 almost fine, no image dissorts. Freezes upon enabling desktop effects
3.) F10 with all xorg-* and lib[xX]* packages from F9 gold surprisingly exibits the same behavior as F10 alone (freezes with image dissorts)

Please let me know if there's some more information I can get to get the problem debugged.
Comment 3 Bug Zapper 2009-06-09 06:19:54 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Vedran Miletić 2009-09-06 05:07:03 EDT
Reporter, please try Fedora 12 Snap1.
Comment 5 Vedran Miletić 2009-09-20 05:00:39 EDT
Bug 478000 is an issue with same chip, very likely the same issue as this one. The other bug has more CCs, and is already ASSIGNED. Closing this one.

*** This bug has been marked as a duplicate of bug 478000 ***

Note You need to log in before you can comment on or make changes to this bug.