This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477332 - Please convert to new font packaging guidelines
Please convert to new font packaging guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: baekmuk-ttf-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caius Chance
Fedora Extras Quality Assurance
: i18n, Reopened
: 481279 (view as bug list)
Depends On:
Blocks: F11-new-font-rules
  Show dependency treegraph
 
Reported: 2008-12-20 12:07 EST by Nicolas Mailhot
Modified: 2009-01-28 16:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 16:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2008-12-20 12:07:01 EST
After more than a month of consultation,
feedback and tweaking new font packaging guidelines have been approved
by FESCO.

http://fedoraproject.org/wiki/PackagingDrafts/Fonts_packaging_automation_(2008-11-18)
http://fedoraproject.org/wiki/Fedora_fonts_policy_package
http://fedoraproject.org/wiki/Simple_fonts_spec_template
http://fedoraproject.org/wiki/Fonts_spec_template_for_multiple_fonts

Package maintainers must now convert their packages in rawhide to the new templates.

The following packages have already been converted in rawhide and can
serve as examples if the templates published in the fontpackages-devel package are not clear enough:

❄ andika-fonts
❄ apanov-heuristica-fonts
❄ bitstream-vera-fonts
❄ charis-fonts
❄ dejavu-fonts
❄ ecolier-court-fonts
❄ edrip-fonts
❄ gfs-ambrosia-fonts
❄ gfs-artemisia-fonts
❄ gfs-baskerville-fonts
❄ gfs-bodoni-classic-fonts
❄ gfs-bodoni-fonts
❄ gfs-complutum-fonts
❄ gfs-didot-classic-fonts
❄ gfs-didot-fonts
❄ gfs-eustace-fonts
❄ gfs-fleischman-fonts
❄ gfs-garaldus-fonts
❄ gfs-gazis-fonts
❄ gfs-jackson-fonts
❄ gfs-neohellenic-fonts
❄ gfs-nicefore-fonts
❄ gfs-olga-fonts
❄ gfs-porson-fonts
❄ gfs-solomos-fonts
❄ gfs-theokritos-fonts
❄ stix-fonts
❄ yanone-kaffeesatz-fonts

FPC and FESCO were not consulted on splitting or renaming packages, nevertheless the new templates make it fare easier to manage subpackages, so you're strongly encouraged to split your packages along font family lines.

A mandatory rule about splitting will probably be submitted for approval before the F11 release.

Further information on fonts packaging changes will be published on fedora-fonts-bugs-list at redhat.com
Comment 1 Caius Chance 2009-01-08 19:14:58 EST
built

http://koji.fedoraproject.org/koji/buildinfo?buildID=77782
Comment 2 Nicolas Mailhot 2009-01-09 09:10:19 EST
Please use the %_font_pkg macro; its an integral part of the official font packaging guidelines.

That will require you to perform the mkfontdir stuff manually and probably put the fonts.scale files in a separate subpackage. Given all the problems we have with core X fonts doing this or even dropping fonts.scale altogether for this package is not necessarily a bad thing
Comment 3 Nicolas Mailhot 2009-01-11 10:19:05 EST
To help packagers manage the transition to the new guidelines, we've published the following FAQ

http://fedoraproject.org/wiki/Shipping_fonts_in_other_packages_(FAQ)
Comment 4 Nicolas Mailhot 2009-01-14 13:36:31 EST
FPC approved those two additional guidelines recently, please take them into account if you need to create or update a fonts package or subpackage:

– 2009-01-14: naming
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_naming_%282009-01-13%29

— 2009-01-06: exact splitting rules
http://fedoraproject.org/wiki/PackagingDrafts/Font_package_splitting_rules_%282008-12-21%29

(packagers that can drop font files and just depend on an existing font package are not impacted)
Comment 7 Nicholas Wourms 2009-01-20 11:14:49 EST
Please update the publican package to reflect this change.
Comment 8 Caius Chance 2009-01-20 18:06:16 EST
thanks mclasen: http://koji.fedoraproject.org/koji/buildinfo?buildID=79589
Comment 10 Nicolas Mailhot 2009-01-22 16:44:43 EST
Transaction Check Error:
  file /usr/share/fonts/baekmuk-ttf/fonts.scale from install of baekmuk-ttf-fonts-common-2.2-16.fc11.noarch conflicts with file from package baekmuk-ttf-common-fonts-2.2-13.fc11.noarch

Your -common subpackage needs to obsolete baekmuk-ttf-common-fonts < 2.2-17
Comment 11 Nicolas Mailhot 2009-01-24 16:18:23 EST
*** Bug 481279 has been marked as a duplicate of this bug. ***
Comment 12 Caius Chance 2009-01-26 19:39:53 EST
(In reply to comment #10)
> Your -common subpackage needs to obsolete baekmuk-ttf-common-fonts < 2.2-17

http://koji.fedoraproject.org/koji/buildinfo?buildID=80378

Obsoletes: baekmuk-ttf-common-fonts < 2.2-17
Comment 13 Nicolas Mailhot 2009-01-28 16:35:52 EST
This one seems ok in the few tests I ran, let's close

Note You need to log in before you can comment on or make changes to this bug.