Bug 477351 - Java plugin fails to run signed applet
Java plugin fails to run signed applet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
https://test.bankid.com/TestBankidCom...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-20 16:14 EST by Göran Uddeborg
Modified: 2009-02-02 10:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 10:40:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2008-12-20 16:14:15 EST
Description of problem:
When I try to run the Swedish electronig signature system "Bank ID" the Java applet implementing it fails to run properly.  At asks for permission to run the signed applet, but then gives an error message.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-7.b12.fc10.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-7.b12.fc10.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Go to https://test.bankid.com/TestBankidCom/Templates/TestPage.aspx?id=22
A window will appear saying "The application's digital signature has been verified.  Do you want to run the application?" and a few details about the signature.
2. Click "Run"
  
Actual results:
A message in white text on blue is shown "Applet was not granted necessary rights and is unable to run.  Please contact your support line if this problem persists."

Expected results:
I thought the latest plugin did support signed applets.

Additional info:
This report is a kind of "reopen" of bug 415061.  That bug was closed as a duplicate of bug 304031, which now is resolved.  But it seems the resolution of the latter bug didn't completely fix the problem in the former.  (Eeven if the behaviour may have changed.)
Comment 1 Jonas Jonsson 2009-01-12 05:25:19 EST
By using java-1.6.0-openjdk-plugin-1.6.0.0-8.b14.fc11.x86_64 from koji the test applet works, but then some other sites that uses the exact same applet still have that problem.

Site that still have the same problem
https://www.kundservice.gemoneybank.se/templates/BIDLogOn.aspx
https://www.csn.se/bas/inloggning/bidt.do

Another site that does work
https://www1.skatteverket.se/pa/pa_easedel/login.do?method=cbt
https://auth1.forsakringskassan.se/necs/bidlogon.jsp
Comment 2 Deepak Bhole 2009-01-22 13:49:36 EST
Thanks for the detailed info! I found the reason why it failed on certain sites with the same applet, but passed on others. It is now fixed upstream and all 5 applets mentioned above, load. the fix will be in the next OpenJDK update for Fedora.
Comment 3 Lillian Angel 2009-02-02 10:40:32 EST
this should be in rawhide within the next couple of days:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1098935

Note You need to log in before you can comment on or make changes to this bug.