Bug 47746 - Disk Partitioning Tool Reads Wrong Existing Partitions
Disk Partitioning Tool Reads Wrong Existing Partitions
Status: CLOSED DUPLICATE of bug 46908
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-06 14:50 EDT by Thornton Prime
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-13 18:07:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thornton Prime 2001-07-06 14:50:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; rv:0.9.1)
Gecko/20010622

Description of problem:
Existing partitions for /dev/hdb and /dev/hdc are read correctly by fdisk,
but the new fangled disk druid (in GUI or text mode) reads partition table
from outer space.

How reproducible:
Always

Steps to Reproduce:
1. Select DiskDruid as partition method, either GUI or text mode.
2.
3.
	

Actual Results:  DiskDruid sees:

/dev/hdb1       1       1       0M      None
/dev/hdb2       1       1       0M      None
/dev/hdb3       1       1       0M      None
/dev/hdb4       1       1       0M      None
/dev/hdb5       1       128     1000M   None
/dev/hdb6       128     256     1000M   None
/dev/hdb7       256     784     4149M   None
Free space      784     784     0M      Free space

/dev/hdc1       1       1       0      None
/dev/hdc2       1       1       0      None
/dev/hdc3       1       1       0      None
/dev/hdc4       1       1       0      None
/dev/hdc5       1       2047    1006   None
/dev/hdc6       2047    2345    146    None
/dev/hdc7       2345    3535    585    None
/dev/hdc8       3535    4155    305    None
/dev/hdc9       4155    4354    97     None
/dev/hdc10      4354    6139    878    None
/dev/hdc11      6139    8184    1006   None
Free space      8184    8184    0      Free space


Expected Results:  fdisk sees:

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1       784   6297448+  fd  Linux raid autodetect


   Device Boot    Start       End    Blocks   Id  System
/dev/hdc1             1      8184   4124704+  fd  Linux raid autodetect


Additional info:
Comment 1 Matt Wilson 2001-07-09 12:12:25 EDT
I *think* this is fixed for beta2.  Please retest with beta2.
Comment 2 Glen Foster 2001-07-13 18:07:25 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 3 Brent Fox 2001-07-25 12:33:39 EDT

*** This bug has been marked as a duplicate of 46908 ***

Note You need to log in before you can comment on or make changes to this bug.