Bug 477678 - incorrect data saved to /etc/sysconfig/network-scripts/ifcfg-eth0
incorrect data saved to /etc/sysconfig/network-scripts/ifcfg-eth0
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 16:36 EST by Need Real Name
Modified: 2008-12-24 05:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-24 05:55:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-12-22 16:36:11 EST
the 
rpm -q system-config-network
system-config-network-1.5.93-2.fc10.noarch
saves incorrect data to 
/etc/sysconfig/network-scripts/ifcfg-eth0
The 
NETMASK field gets value of IP address or gateway.
Thus the static eth0 interface created by system-config-network
is unusable.
Only manual edit of /etc/sysconfig/network-scripts/ifcfg-eth0
and setting NETMASK=255.255.255.0 
can make interface working.
Comment 1 Jonathan S. Shapiro 2008-12-23 09:14:14 EST
The problem is somewhat worse than described. If the ifcfg-ethX file is hand-edited, and system-config-network is re-run, then the netmask field is once again mis-set and the machine is effectively taken off of the network.

Priority on this should be changed to *high*, because this will break connectivity for every unsophisticated user who is configured using static IP.

I haven't looked at source for this (traveling), but this really smells like somebody made a sloppy two line change somewhere and didn't even make a casual test.
Comment 2 Jiri Moskovcak 2008-12-24 05:55:11 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.