Bug 477709 - Logwatch runs when system rebooted
Logwatch runs when system rebooted
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
: 487686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-22 19:14 EST by Ray Todd Stevens
Modified: 2009-03-02 09:12 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.3-63.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 09:27:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is the cron log (7.82 KB, application/octet-stream)
2008-12-23 14:24 EST, Ray Todd Stevens
no flags Details
cron log (7.82 KB, text/plain)
2008-12-23 14:26 EST, Ray Todd Stevens
no flags Details

  None (edit)
Description Ray Todd Stevens 2008-12-22 19:14:03 EST
Description of problem:

Log watch not only runs at the scheduled time, but each time the server is rebooted.  OK this is not a biggee, but it is a difference from previous behavior.  


Version-Release number of selected component (if applicable):

FC10 as upgraded

How reproducible:

Each time a reboot

Steps to Reproduce:
1.  reboot
2.  read email
Comment 1 Ivana Varekova 2008-12-23 02:53:24 EST
Reassign to cronie component this is not logwatch bug.
Comment 2 Marcela Mašláňová 2008-12-23 07:45:37 EST
I suppose you have logwatch in daily jobs (/etc/cron.daily). If you restart your computer before all daily jobs runned, then they will start again after reboot.

Could you please attach log from /var/log/cron? Thank you.
Comment 3 Ray Todd Stevens 2008-12-23 14:22:10 EST
Well all of the daily jobs should have run.   Daily basically runs a 4am or there abouts and this problem has been observed in the noon to 5pm window.
Comment 4 Ray Todd Stevens 2008-12-23 14:24:39 EST
Created attachment 327765 [details]
this is the cron log

It is running daily, and I am not sure why.

PS this has happened more than once.
Comment 5 Ray Todd Stevens 2008-12-23 14:26:55 EST
Created attachment 327766 [details]
cron log

Trying again.   It didn't seem to like text last time.
Comment 6 Ray Todd Stevens 2008-12-26 22:38:10 EST
OK I think I have this one.

It is definately not rebooting that is doing this.

It is the reboot after I do a yum update.  and then only once.   The sessions that seem to be causing this problem, and I am getting it once per server are ones that are doing a bunch of specific updates including something to the crontabs.   Is it possible that installing an updated version of this file is messing with something?
Comment 7 Michal Jaegermann 2009-01-01 16:25:30 EST
This is possibly the same as bug 472275. It looks like that when vixie-cron was replaced by cronie then a cooperation between cron and anacron was seriously broken.  Now anacron runs jobs completely disregarding if they were already perfomed or not and makes a mess.  This happens in F8 and F9 and F10.
Comment 8 Matt Castelein 2009-01-27 16:27:35 EST
I am not sure what the trigger is, but my anacron occasionally runs cron.daily when it's already run for that day.  I notice it because I get two logwatch emails for the same day.
Comment 9 Ray Todd Stevens 2009-01-27 16:37:00 EST
Yeah I have been having this problem.  Generally some times when I reboot.  Usually seems to be related to doing an update.   Interestingly enough I can reboot, do an update, and reboot.  Then the second and not the first reboot will trigger this.
Comment 10 Matt Castelein 2009-01-27 16:53:15 EST
Yeah, I installed mgetty today and rebooted several times to make sure the stuff I put in /etc/event.d was all working.  I wasn't paying attention to the order per se, but I installed a few packages and rebooted a couple times.  logwatch (and cron.daily) ran as it was supposed to at 4 AM, then anacron ran it again at a quarter past 4 PM, and I got a second email.
Comment 11 Marcela Mašláňová 2009-01-28 08:32:21 EST
I push update for testing. Please install crontabs and anacron from testing repository or go to the link below and let me know about possible problems. This solution is not nice, but it should be working. The bigger changes are planned for next release.
Comment 13 Fedora Update System 2009-01-29 18:08:29 EST
anacron-2.3-66.fc10, crontabs-1.10-26.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anacron crontabs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1163
Comment 14 Marcela Mašláňová 2009-01-30 09:05:25 EST
Could someone verify this fix?
Comment 15 Matt Castelein 2009-01-30 09:27:46 EST
(In reply to comment #14)
> Could someone verify this fix?

I will try it out.
Comment 16 Matt Castelein 2009-01-30 09:34:56 EST
[root@arturo ~]# yum --enablerepo=updates-testing --disableplugin=protectbase update anacron crontabs
Setting up Update Process
No Packages marked for Update

Where are they?
Comment 17 Marcela Mašláňová 2009-01-30 09:47:04 EST
Good question. Probably it takes more time to sync updates from bodhi to mirrors.
Comment 18 Matt Castelein 2009-01-30 10:06:01 EST
(In reply to comment #17)
> Good question. Probably it takes more time to sync updates from bodhi to
> mirrors.

As soon as I get my hands on it, I will test it.
Comment 19 Ray Todd Stevens 2009-01-30 10:18:57 EST
I think the real proof will be in several of us getting the update installed, and the doing at least a couple full yum updates and reboots and a couple more reboots over a period of a week or so.   After all this one seems to be a bit elusive in exactly when it occurs, or at least that seems to be my experience.
Comment 20 Marcela Mašláňová 2009-01-30 10:38:58 EST
I agree. The update stays in testing until confirmation from more users.
Comment 21 Matt Castelein 2009-01-30 10:40:34 EST
I can pretty much count on my system exhibiting this behavior after every reboot, so I'll start with that.  But I agree also, input from others is required.
Comment 22 Lucas Nealan 2009-01-31 18:28:08 EST
I'm experiencing this problem on fc9, booted last night at 02:25 after swapping some memory. Anacron started cron.daily at 02:25, it then delayed and ran normally again from crond at 04:02. I have some long running backup scripts in cron.daily that wound up running concurrently.

The default 65 minute delay pushed the anacron started cron.daily to 03:30, then 000-delay.cron pushed it again 04:19. At the same time the crond cron.daily delayed until 04:50.

Jan 31 04:40:55 run-parts(/etc/cron.daily)[18685]: starting 850.backup
Jan 31 04:52:32 sizzo run-parts(/etc/cron.daily)[10450]: starting 850.backup

Will the updated package only be going into f10?
Comment 23 Marcela Mašláňová 2009-02-02 01:25:28 EST
The update will be also for F-9.
Comment 24 Matt Castelein 2009-02-03 09:45:42 EST
Installed anacron-2.3-66.fc10 and crontabs-1.10-26.fc10 on my system, and the behaviour of anacron after a reboot is normal.  The fix looks good from here.
Comment 25 Fedora Update System 2009-02-04 21:17:58 EST
anacron-2.3-63.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update anacron'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1317
Comment 26 Ray Todd Stevens 2009-02-05 09:48:12 EST
Seems to be fixed here too.  (FC10)
Comment 27 Ray Todd Stevens 2009-02-09 12:37:17 EST
This bug is now occurring in Redhat Enterprise Server.
Comment 28 Marcela Mašláňová 2009-02-10 06:13:38 EST
Changes which lead to this bug weren't applied in RHEL. If you see jobs executed twice then I need more information about version of RHEL and releases of packages.
Comment 29 Ray Todd Stevens 2009-02-10 08:16:06 EST
OK interesting.   I ran an update on three of these servers and got the extra run of the log watch program that we have been seeing here.   You might want to double check if this was indeed not pushed to this version.

In the mean time I will see if I can duplicate the problem and will go through normal support channels if it is.   

I only noted here, because it was the same symptom.
Comment 30 Marcela Mašláňová 2009-02-24 09:27:48 EST
I hope this was tested for a long time and well. Let's move it to stable.
Comment 31 Fedora Update System 2009-02-25 11:22:45 EST
anacron-2.3-66.fc10, crontabs-1.10-26.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2009-02-25 11:23:03 EST
anacron-2.3-63.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Marcela Mašláňová 2009-03-02 09:12:33 EST
*** Bug 487686 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.