Bug 487686 - anacron has lost its marbles, is round the bend, is off its chum, has gone mental...
anacron has lost its marbles, is round the bend, is off its chum, has gone me...
Status: CLOSED DUPLICATE of bug 477709
Product: Fedora
Classification: Fedora
Component: anacron (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-02-27 09:04 EST by Tom Horsley
Modified: 2009-03-02 09:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-03-02 09:12:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2009-02-27 09:04:04 EST
Description of problem:

I just got mail that anacron just ran cron.weekly. The normal cron.weekly
job ran just fine early Sunday morning like always. The next cron.weekly
job isn't scheduled to run until next Sunday. What in the blue blazes
is anacron doing running it now? Any missed cron activity was entirely
in anacron's imagination.

Version-Release number of selected component (if applicable):
anacron.i386 0:2.3-66.fc10

How reproducible:
Apparently utterly random.

Steps to Reproduce:
1. No idea.
Actual results:

Anacron running stuff for no reason at all.

Expected results:

Anacron acting sane.

Additional info:

I actually don't want anacron at all. This machine is up 99% of the time
and if it happens to be down when cron has a job scheduled, too bad, it
will get it the next time. I just removed anacron in an attempt to stop
the insanity, but I see another bugzilla that claims everything stops
working without anacron. I hope that is only in rawhide.

I have often suspected similar nonsense with cron.daily, but this weekly
run in the middle of the week is far too obvious to overlook.
Comment 1 Tom Horsley 2009-02-27 15:14:36 EST
I looked in the yum log and see that anacron-2.3-66.fc10.i386
just arrived in updates yesterday. Did it completely change the
way it does everything or something and therefore convinced
itself that cron.weekly hadn't run this week?
Comment 2 Marcela Mašláňová 2009-03-02 02:52:13 EST
For F-10 it was only updates, so that was only bug fixing #477709. Users confirm the fix.
Comment 3 Marcela Mašláňová 2009-03-02 09:12:33 EST
As reported on F-10 closing as duplicate. The update spent a long time in testing, so I suppose it's tested well.

*** This bug has been marked as a duplicate of bug 477709 ***

Note You need to log in before you can comment on or make changes to this bug.