Bug 477810 - Error when choosing "Search for files" from a folder quick menu
Error when choosing "Search for files" from a folder quick menu
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus-search-tool (Show other bugs)
10
All Linux
low Severity urgent
: ---
: ---
Assigned To: Paul W. Frields
Fedora Extras Quality Assurance
:
: 498244 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 16:13 EST by Braden McDaniel
Modified: 2009-08-08 15:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-18 15:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The error dialog I get when right-clicking on the desktop and selecting "Search for Files..." (14.20 KB, image/png)
2008-12-23 16:13 EST, Braden McDaniel
no flags Details
Search tool cannot stat existing directory. (101.40 KB, image/png)
2009-01-13 11:11 EST, markm
no flags Details

  None (edit)
Description Braden McDaniel 2008-12-23 16:13:17 EST
Created attachment 327770 [details]
The error dialog I get when right-clicking on the desktop and selecting "Search for Files..."

Description of problem:
This seems to be broken.  That is, right-clicking on a folder and selecting "Search for Files..." doesn't result in a search at that location.  It brings up the "Search for Files" app alright--along with a dialog box saying it can't find the directory.  The path given in the dialog box suggests that the actual path has been mangled.

Version-Release number of selected component (if applicable):
0.2.2-4.fc10

How reproducible:
Consistently.
Comment 1 Didier G 2009-01-06 20:33:49 EST
I have exactly the same problem with same dialog error.
Comment 2 Didier G 2009-01-08 07:40:18 EST
I rebuilt a RPM for Fedora 10 from nautilus-search-tool-0.2.2-8.fc11.src.rpm found on Koji but problem still exists with this version.
Comment 3 markm 2009-01-13 11:11:45 EST
Created attachment 328883 [details]
Search tool cannot stat existing directory.

I have the same issue, though searching works when I dismiss this error.
see screenshot attached.
Comment 4 Paul W. Frields 2009-07-11 11:49:53 EDT
*** Bug 498244 has been marked as a duplicate of this bug. ***
Comment 5 Chess Griffin 2009-07-13 23:08:38 EDT
This *might* have been fixed in latest 0.3.0 upstream release.  From their Changelog:

2009-04-12  Andrea Zagli <azagli@libero.it>

	* added turkish translation (thanks to Yavuz Selim)
	* fixes to work with nautilus >= 2.22 (thanks to nautilus-open-terminal
	  authors)
	* fixes to work with gnome-utils => 2.22
	* version 0.3.0
Comment 6 Chess Griffin 2009-07-15 12:48:39 EDT
I am working on an updated 0.3.0 spec & SRPM to see if this fixes things.
Comment 7 Chess Griffin 2009-07-15 20:48:02 EDT
I updated the spec and SRPM to version 0.3.0 and it seems to work fine on my Fedora 11 box.  Rpmlint -vi on the spec, SRPM, and RPM are clean, no warnings or errors.  I also cleaned up the spec and removed some of the patches that were no longer needed.  It builds fine in Koji for dist-f11[1] and dist-f12[2].

SPEC URL:
http://chessgriffin.com/files/pkgs/fedora/nautilus-search-tool/nautilus-search-tool.spec

SRPM URL:
http://chessgriffin.com/files/pkgs/fedora/nautilus-search-tool/nautilus-search-tool-0.3.0-1.fc11.src.rpm

[1] https://koji.fedoraproject.org/koji/taskinfo?taskID=1477306
[2] https://koji.fedoraproject.org/koji/taskinfo?taskID=1477388
Comment 8 James 2009-07-18 11:02:06 EDT
I find n-s-t-0.3.0-1.fc11 crashes nautilus when I try to use it.
Comment 9 Paul W. Frields 2009-07-18 14:28:04 EDT
Can you try this package instead?  (If you download it manually, you may need to 'yum remove nautilus-search-tool' before you install the new one.  If you simply click on the package and let PackageKit handle it, everything will work fine.)  It works for me without crashing:

http://koji.fedoraproject.org/koji/buildinfo?buildID=114971
Comment 10 James 2009-07-18 14:46:43 EDT
Now it works, thanks.
Comment 11 Fedora Update System 2009-07-18 15:18:23 EDT
nautilus-search-tool-0.3.0-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nautilus-search-tool-0.3.0-2.fc11
Comment 12 Fedora Update System 2009-07-18 15:18:27 EDT
nautilus-search-tool-0.3.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nautilus-search-tool-0.3.0-2.fc10
Comment 13 Fedora Update System 2009-08-08 15:27:37 EDT
nautilus-search-tool-0.3.0-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.