Bug 477847 - ThinkPad X200 Suspends again on first resume if suspended using function keys
ThinkPad X200 Suspends again on first resume if suspended using function keys
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 02:30 EST by Amit Shah
Modified: 2015-03-04 20:20 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 07:57:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2008-12-24 02:30:24 EST
Description of problem:

If I suspend my X200 laptop using the Fn+F4 key (suspend-to-ram) and then wake it either by opening the lid or by pressing the power key, it resumes fine but immediately again goes into suspend.

When I tried suspend-to-disk (Fn+F12) in the same way, it first suspends to ram. When I press the power button, it wakes up and then finishes the process of suspending to disk.

Using the 'Suspend to Disk' and 'Suspend to RAM' from the logout menu (I use KDE, so F->Leave->Suspend to X works fine and as expected.

$ rpm -q pm-utils
pm-utils-1.2.2.1-2.fc10.x86_64
Comment 1 Fedora Update System 2009-01-16 07:37:19 EST
gnome-power-manager-2.24.3-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/gnome-power-manager-2.24.3-1.fc10
Comment 2 Amit Shah 2009-01-16 08:34:03 EST
Note: I use KDE, so I don't think this will solve this.
Comment 3 Ngo Than 2009-01-16 10:30:01 EST
does the problem happen if you use gnome desktop?
could you please try  lshal -m to get the events before you activate suspend?

thanks
Comment 4 Fedora Update System 2009-01-16 18:47:38 EST
gnome-power-manager-2.24.3-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnome-power-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0672
Comment 5 Amit Shah 2009-01-20 05:06:33 EST
I don't have gnome installed, so I can't say.
Comment 6 Fedora Update System 2009-01-29 18:09:17 EST
gnome-power-manager-2.24.3-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Amit Shah 2009-01-30 08:51:23 EST
Can this bug please be disconnected from the gnome-related updates?
Comment 8 Amit Shah 2009-08-13 10:03:43 EDT
Using F11 now, with gnome and experiencing the same:

Fn+F4 suspends. Opening lid resumes but suspends immediately.

Selecting 'suspend' from the power applet doesn't show that behaviour.
Comment 9 Amit Shah 2009-08-29 06:02:01 EDT
Works for me with gnome desktop after the updates mentioned in Bug 497743 (haven't tried with KDE)

Note You need to log in before you can comment on or make changes to this bug.