Bug 47788 - Installer cannot make bootdisk after bootloader failure, also can freeze with certain package selections
Installer cannot make bootdisk after bootloader failure, also can freeze with...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-07 13:40 EDT by William M. Quarles
Modified: 2007-03-26 23:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-29 16:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William M. Quarles 2001-07-07 13:40:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
When installing LILO in graphical-mode upgrade, it is possible to receive 
an error message saying that there was an error installing the boot 
loader, and the specific error I received was "No images have been 
defined."  It also then HIGHLY reccomends making a bootable floppy.  Once 
this step is reached, the program will continously detect a problem with 
the floppy, even if it is a brand new MS-DOS formatted disk (which is what 
the HOW-TO calls for).  Linux ext2fs formatted disks were also attempted.

See "Additional info" regarding pacakge selections.

How reproducible:
Always

Steps to Reproduce:
1.Boot from installation CD on a system with a screwed-up kernel 
installation
2.Run graphical mode
3.Preform upgrade
4.Select all system and interface packages (you can leave out the foreign 
langauge ones if you like)
5.Get "No images have been defined" error message
6.Attempt to create bootable floppy with a freshly formatted MS-DOS 1.44 
MB floppy.
	

Actual Results:  The installer returns an error for the drive/disk, and 
asks you to try again.

Expected Results:  Installer should accept the disk and make it a linux 
bootdisk for your system

Additional info:

I have also encountered a problem when installing only one or zero 
packages from Disc 2, it tends to freeze the installer during the 
finishing step of the installation of the packages.  That is why I 
reccomended selecting so many packages.  I do not know whether or not 
these are related, even if only by the bootloader error, so I have 
submitted them together.
Comment 1 Brent Fox 2001-07-10 01:06:57 EDT
In step one, when you say "screwed up kernel installation"...how screwed up is
it?  Did the system even boot before you tried the upgrade?
Comment 2 William M. Quarles 2001-07-15 15:04:59 EDT
No boot happened.

This also might be related to a problem in the kernel-2.4.3-12-i386.rpm that 
was released, but let's address the installer bug first.

Please read my initial descrpition of the bug again first, just in case any 
knowledge is missing.

For a bit of background, our floppy drive had a slight mechanical problem 
accepting disks.  I corrected it at sometime during this mishap, and it was 
simply a plastic "cover button" attached to the plastic face of our computer 
was jamming with the face.  Remove the face, no more jam.  I later filed down 
some defects in the cover button to correct the problem.  I was able to boot 
from an MS-DOS bootdisk, which did little to help me but verified that the 
drive could at least read, accept, and eject disks.  I was under the impression 
that no linux bootdisk was made during our original 6.2 to 7.1 upgrade a week 
before this incident, since the drive acceptance mechanism had been jammed for 
at least two months prior to this day.

------------

Now a more complete procedure:

1. I was not very familiar with linux kernels before I did this.  I am still 
not familiar with how kernel upgrade rpms work.  Then again, nobody seems to 
have written a HOW-TO on upgrading kernels.  Maybe I should if I can get more 
information on them.  But I installed the 2.4.3 kernel upgrade rpm,

2. then deleted several directories relating to the 2.4.2 kernel, since they 
were left during the upgrade.  I thought this would be harmless, but I was 
being fast and bullheaded rather than allowing my computer to reboot and make a 
bootdisk.  But I am not sure whether or not that caused our next problem.

3. On reboot, lilo hung after displaying its RedHat graphical mode, when it 
said "Starting Linux..." or whatever it says, I'm on a Windows machine at home 
now so I don't recall and can't remind myself.  Again, Lilo could not start 
Linux.

4. Tried doing the RedHat 7.1 Upgrade to restore files, selected all of the 
system and interface packages, as well as install Lilo, and I received the 
error message that I described in my initial description of the bug.  Quoting 
from there, "When installing LILO in graphical-mode upgrade, it is possible to 
receive an error message saying 'there was an error installing the boot 
loader,' and the specific error I received was 'No images have been 
defined.'  It also then HIGHLY reccomends making a bootable floppy."

5.  The rpms still installed/upgraded (usually, but it would on some occasions 
freeze up requiring a CTRL-ALT-BACKSPACE and a reboot), then when it came to 
making a bootdisk, the installer would keep telling me something to the effect 
of "There was an error reading the disk that you inserted.  Please insert a 
formatted disk into the first floppy drive, then try again."  It would read for 
about a second, then refuse the disk, no matter what format it had, MS-DOS or 
ext2.  These were brand new disks I was trying.

6. I even tried reformatting the disks in both formats on other computers, and 
even swapping the floppy drive for another one that I had on hand and doing the 
upgrade again, and it did not make a difference.  Statistically speaking, if I 
use four brand new disks all write-enabled, and two different drives, there is 
little chance for the error coming from my equipment.

7. On completion of the setup and reboot (with no removable media in any of the 
drives), the system will not boot from the hard disk.  The result was very 
similar to the problem experienced during the initial boot after the attempted 
kernel upgrade, step 3.  I think the only difference was originally several 
ellipses were printed after "Starting Linux," then it stopped the computer 
completely; now no ellipses were printed following "Starting Linux," and it 
stopped the computer completely.  It might have been vice versa, but I don't 
know if that's relevant.

8.  Luckily someone, somehow, made a bootdisk during our original 7.1 upgrade, 
which I found after writing up this bug originally.  This surprised me because 
last I knew, the floppy drive we were using at the time had a jammed acceptance 
mechanism for two months until this day that I figured out how to fix this.  I 
thought God must have just decided to bless me at that moment, and I haven't 
asked who made the bootdisk, so I will leave it at that.  I rebooted using the 
orignal 7.1 bootdisk.  Again, this was made during our original 7.1 upgrade 
about a week prior, and not anywhere in this mishap.  Hard drives mounted, CD-
ROM access wasn't allowed for some reason.  XWindows could start.

9. I had to recompile the kernel from scratch using the 2.4.3 kernel headers 
and sources rpms to get the computer to run again.  After the kernel 
configuration and complilation, I made a new bootdisk using the "make bzdisk" 
command in the /usr/src/linux-2.4.3-12/ directory, which was successful.  It 
rebooted from the bootdisk, and it worked.  Again, nothing wrong with our 
floppy drive, nothing wrong with our disks.  After reconfiguring lilo to read 
the new image I made, it was able to boot from the hard disk, too.

----------

I now know more about kernels than I really want to.  I still don't know how 
that darned upgrade kernel rpm is supposed to work, and I'm not going to try 
using it again unless it is really necessary to solve this problem.
Comment 3 Brent Fox 2001-08-10 14:46:41 EDT
So it sounds like you tried the upgrade on a system that was already unbootable.
 This means that the upgrade has very little chance of succeeding.  I think that
if the system wasn't already in a messed up state, the upgrade would have worked
fine.

By the way, a document for upgrading your kernel is available at:
http://www.redhat.com/support/docs/howto/kernel-upgrade/kernel-upgrade.html.

It seems to me that something went wrong during the kernel upgrade which
prevented the upgrade for working.  I would try a reinstall of 7.1 and see if
that solves the problem.
Comment 4 William M. Quarles 2001-08-19 17:15:57 EDT
Okay, let me try this again.  Don't you see it as a problem if the installer
tells the user "It is HIGHLY reccomended that you make a bootdisk" if the
bootdisk can't actually be made?
Comment 5 William M. Quarles 2001-08-19 20:16:37 EDT
Okay, try this on for size:

1.  Just to remind you, I installed the 2.4.3 headers and sources and 
compiled a new kernel rather than "re-installing" since that would require 
me to wipe a lot of partitions pointlessly.  Then I (screw up) need to 
reinstall some critical packages or experience a problem with LILO or 
something, so I go through the upgrade process again with the 7.2 
installation CD.  Now, as it turns out, lilo.conf has some typos in it.  The 
wrong partition is labeled as the root partition, and the last line reads 
"read-onl" rather than "read-only".  So I go through the ugrade, te 
pacakges install, and tehn we get the expected bootloader error again, 
only instead this time it says that there is a syntax error in lilo.conf.  The 
installer does not detect the root partition typo, even though it already 
detected the correct partition on the lilo installation form.  However, it does 
detect the other typo.  Guess what it says along with this error message?  
"It is HIGHLY reccommended that you make a bootable floppy."  My guess 
is, that unless the installer is smarter than I think it is (which it does not 
seem so smart from the last example) the creation of the bootable floppy 
is going to fail, even though the image is intact and the installer could 
possibly do it.  Finally we get to the page where we are asked to insert a 
floppy, and it again fails, even though (I think at least) there is a way that it 
could work here, and even though we were just "HIGHLY reccomended" to 
make this boot floppy.

2.  Okay, so now let's say lilo.conf is fixed.  I had to use the rescue mode 
on the 6.2 installation disc to get it done (see bug#52055), but it is done.  
Let's try this re-upgrade again.  Guess what?  It still doesn't make the 
bootable floppy.

3.  I can make a bootdisk manually without the installation CD-ROM from 
the command line.  Go figure!
Comment 6 Matt Wilson 2001-08-24 18:26:10 EDT
I think this is a dup, feel free to comment if you disagree


*** This bug has been marked as a duplicate of 52099 ***
Comment 7 William M. Quarles 2001-08-29 16:58:03 EDT
I tried viewing the bug that you marked mine as a dup of, and this is what I
saw:

Permission denied.

                                               Sorry; you do not have the
permissions necessary to see bug 52099.
Comment 8 Brent Fox 2001-08-29 17:46:20 EDT
According to bug #52099, this error has been fixed in Rawhide.  Thanks for your
report.

Note You need to log in before you can comment on or make changes to this bug.